Bug 249531 - yum crashes on update while processing glibc conflict
yum crashes on update while processing glibc conflict
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-25 09:31 EDT by Patric Schmitz
Modified: 2014-01-21 17:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-03 16:38:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patric Schmitz 2007-07-25 09:31:00 EDT
Description of problem:
yum crashes when 'yum update' is called. after (many) packages are marked for an
update, it begins processing the conflict:
--> Processing Conflict: glibc-common conflicts glibc < 2.6
and crashes.

Version-Release number of selected component (if applicable):
3.2.1

How reproducible:
yum update

Steps to Reproduce:
1. yum update
2.
3.
  
Actual results:
...
...
---> Package firefox.i386 0:2.0.0.5-1.fc7 set to be updated
---> Package cvs.i386 0:1.11.22-9.1.fc7 set to be updated
--> Processing Dependency: libkcal.so.2 for package: kdesdk
--> Processing Dependency: libsexy.so.2 for package: xchat
--> Processing Conflict: glibc-common conflicts glibc < 2.6
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 135, in main
    (result, resultmsgs) = base.buildTransaction() 
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 527, in
buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 871, in resolveDeps
    (checkdep, missing, conflict, errormsgs) = self._processConflict(dep)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 665, in
_processConflict
    except PackageSackError:
NameError: global name 'PackageSackError' is not defined

Expected results:
successful package update.

Additional info:
i have the following repos enabled:
adobe-linux.repo
fedora-development.repo
fedora.repo
fedora-updates.repo
fedora-updates-testing.repo
livna-devel.repo
livna.repo
livna-testing.repo

the system was installed as fedora core 6 and then (successfully as i see it)
upgraded to fedora 7. then there was no upgrade for a longer period. now the
error occurs.
Comment 1 Jeremy Katz 2007-07-25 09:50:17 EDT
What version of glibc and glibc-common do you have installed?  

Fixed up the traceback upstream, though
Comment 2 Patric Schmitz 2007-07-27 05:33:23 EDT
glibc.i686                               2.5-10.fc6       installed
glibc.i686                               2.6-3            installed
glibc-common.i386                        2.5-10.fc6       installed
glibc-common.i386                        2.6-3            installed
glibc-devel.i386                         2.6-3            installed
glibc-headers.i386                       2.6-3            installed

ah i see the problem, there are old fc6 packages which didn't get
upgraded/removed automatically.

yum remove glibc-2.5-10.fc6 glibc-common-2.5-10.fc6

solves the problem. i could have checked that myself.. well a strange error
anyway, and yum should be able to deal with such a situation, at least without
crashing. or it should have made a clean update from fc6 to f7 in the first place..
Comment 3 Seth Vidal 2007-07-27 12:39:47 EDT
Well the crash was just an exception not being grabbed. The issue that led up to
it, however, would be nice to recreate.
Comment 4 Seth Vidal 2007-08-03 16:38:09 EDT
however, since the specific case is fixed - closing the bug

Note You need to log in before you can comment on or make changes to this bug.