Bug 249561 - updatedb not function under the 2.6.22.1-27.fc7 kernel
Summary: updatedb not function under the 2.6.22.1-27.fc7 kernel
Status: CLOSED DUPLICATE of bug 242715
Alias: None
Product: Fedora
Classification: Fedora
Component: mlocate   
(Show other bugs)
Version: 7
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-25 15:21 UTC by eric@christensenplace.us
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-26 14:55:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description eric@christensenplace.us 2007-07-25 15:21:23 UTC
Description of problem:
When running updatedb I get the following error:
updatedb: src/updatedb.c:721: scan_cwd: Assertion `name_size > 1' failed

This only happens when using the 2.6.22.1-27.fc7 kernel.  The command works
properly under the 2.6.21-1.3228.fc7 kernel.

Version-Release number of selected component (if applicable): Unknown


How reproducible: Each time.


Steps to Reproduce:
1. "updatedb" under root
  
Actual results:
updatedb: src/updatedb.c:721: scan_cwd: Assertion `name_size > 1' failed

Expected results:
For the db to be updated so "locate" will work.

Additional info:

Comment 1 Zing 2007-07-26 00:08:42 UTC
something in /sys is confusing updatedb...

WORKAROUND: if you add "sysfs" to the PRUNEFS variable in /etc/updatedb.conf,
updatedb should succeed... it does on mine.

Comment 2 eric@christensenplace.us 2007-07-26 00:24:31 UTC
I just tried it and it seems to work.  Thanks!

Comment 3 Zing 2007-07-26 14:55:13 UTC

*** This bug has been marked as a duplicate of 242715 ***


Note You need to log in before you can comment on or make changes to this bug.