Bug 249586 - prelink should not run when system is running on battery
prelink should not run when system is running on battery
Status: CLOSED DUPLICATE of bug 190268
Product: Fedora
Classification: Fedora
Component: anacron (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-25 12:03 EDT by Thorsten Leemhuis
Modified: 2009-09-21 17:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-30 10:26:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Leemhuis 2007-07-25 12:03:54 EDT
Description of problem:
prelink is quite hard disk and CPU insensitive -- as updating the cache
regularly is a nice to have, but not crucial task (at least afaik) I'd say the
cron job should only run if the system is running on AC power. 

Thus I think a simple check for existence of /usr/bin/on_ac_power, running it,
checking its return code and aborting if running on battery would be a nice
addition to the cron script. I'm willing to write something up and testing it in
case you indicate to agree with the idea and such a patch in general.
Comment 1 Jakub Jelinek 2007-07-25 14:55:15 EDT
That's business of anacron/crond, there are many other cron jobs that shouldn't
be running when on batteries and requiring each to do it on its own is a bad
idea.
Comment 2 Thorsten Leemhuis 2007-07-26 07:27:23 EDT
(In reply to comment #1)
> That's business of anacron/crond, there are many other cron jobs that shouldn't
> be running when on batteries and requiring each to do it on its own is a bad
> idea.

I see the point -- but for some other cron jobs it might be important to run
even when on battery.
Comment 3 Marcela Mašláňová 2007-07-30 10:26:35 EDT

*** This bug has been marked as a duplicate of 190268 ***

Note You need to log in before you can comment on or make changes to this bug.