Bug 249587 - Need to install mdadm before kernel
Need to install mdadm before kernel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-07-25 12:28 EDT by Orion Poplawski
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-10 10:57:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2007-07-25 12:28:10 EDT
Description of problem:

Seeing the following in my install.log:

Installing mkinitrd - 6.0.9-7.1.i386
Installing kernel - 2.6.22.1-27.fc7.i686
cp: cannot stat `/sbin/mdadm': No such file or directory

This results in a initrd that doesn't boot machines with root on a md device. 
Fix I believe is to add mdadm to kernel_prereq so that it is present when
mkinitrd is run.

There seem to be a number of mkinitrd bugs filed that are similar to this,
though many also have other issues reported as well.

Version-Release number of selected component (if applicable):
2.6.22.1-27.fc7
Comment 1 Will Woods 2007-08-01 12:50:23 EDT
This is definitely a mkinitrd problem, not a kernel problem (kernel %post script
uses mkinitrd to create the initrd - mkinitrd needs mdadm to function properly).

What mkinitrd bugs did you find that were similar to this one? Bug #244539 might
be the same thing.

This also manifests in rawhide / current F8t1 candidates - adding to F8t1 tracker.
Comment 2 Will Woods 2007-08-02 00:59:06 EDT
This might be better to fix by ensuring mdadm is installed before kernel in
anaconda, since the other two possibilities are:

1) any system with pre-existing RAID should already have mdadm, and
2) non-RAID systems don't need mdadm at all.

This is how we handle iscsi-initiator-utils as well.
Comment 3 Orion Poplawski 2007-08-26 21:15:42 EDT
Re-assigning to anaconda so that maybe there is some hope of being able to
successfully install software raid systems again sometime.
Comment 4 Jeremy Katz 2007-09-10 10:57:44 EDT
mkinitrd requires mdadm now, so the ordering should end up correct.  Still
working with Panu to come up with a more general way of hinting this to rpm
without the requires

Note You need to log in before you can comment on or make changes to this bug.