Bug 249592 - Cannot use 'Manual configuration' for Times
Cannot use 'Manual configuration' for Times
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fwbackups (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Stewart Adam
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-25 12:52 EDT by groug
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 1.43.1-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-27 01:53:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Use correct field names in ui (1.04 KB, patch)
2007-07-25 13:22 EDT, groug
no flags Details | Diff

  None (edit)
Description groug 2007-07-25 12:52:25 EDT
Description of problem:

After using 'Manual Configuration' in the 'Times' page, the set can never be
edited again because an exception in guiwidgets.py.

Version-Release number of selected component (if applicable):

fwbackups-1.43.1-1.fc7

How reproducible:

Always.

Steps to Reproduce:
1. create a set
2. choose 'Manual Configuration' in the 'Times' page
3. put * in all fields
4. save
5. try to edit the set

Actual results:

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/fwbackups/guicallbacks.py", line 561,
in on_EditSetButton_clicked
    self.SetView1.edit()
  File "/usr/lib/python2.5/site-packages/fwbackups/guiwidgets.py", line 1376, in
edit
    self._restore(set)
  File "/usr/lib/python2.5/site-packages/fwbackups/guiwidgets.py", line 1039, in
_restore
    self.ui.SetManualMinuteEntry.set_text(l[0])
  File "/usr/lib/python2.5/site-packages/fwbackups/guicallbacks.py", line 56, in
__getattr__
    (`name`, `self.filename`))
AttributeError: Can't find widget 'SetManualMinuteEntry' in
'/usr/share/fwbackups/fwbackups.glade'.

Expected results:

no exception.

Additional info:

patch provided.
Comment 1 groug 2007-07-25 13:22:55 EDT
Created attachment 159961 [details]
Use correct field names in ui
Comment 2 Stewart Adam 2007-07-25 13:43:31 EDT
Thank you for the patch, a package with the patch included is rebuilding now.
Comment 3 Fedora Update System 2007-07-27 01:53:41 EDT
fwbackups-1.43.1-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.