Bug 249603 - gcc segmentation fault.
Summary: gcc segmentation fault.
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc4   
(Show other bugs)
Version: 7
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard: /tmp/cc6QneJE.out
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-25 18:16 UTC by Artur Penttinen
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-25 18:50:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Artur Penttinen 2007-07-25 18:16:05 UTC
Description of problem:
Internal compiler error with -g flag.

Version-Release number of selected component (if applicable):
# gcc --version
gcc (GCC) 4.1.2 20070502 (Red Hat 4.1.2-12)
# uname -r
2.6.21-1.3194.fc7
# 


How reproducible:


Steps to Reproduce:
1. 
# cat > a.c
int main ()
{
        return 1;
}
^D
2.
# gcc a.c
#
3.
# gcc -g a.c
a.c:4: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/cc6QneJE.out file, please attach this to
your bugreport.
#
  
Actual results:
internal compiler error

Expected results:
a.out

Additional info:
by request

Comment 1 Jakub Jelinek 2007-07-25 18:50:26 UTC
If such a trivial testcase doesn't compile, then it can be either a hardware
issue (bad RAM, overclocked CPU, ...) or you have corrupted binary
(you can e.g. run rpm -V gcc cpp to verify the latter).
It compiles with -g just fine here (and of course it couldn't make it
through the extensive testing that is done during each build).

Comment 2 Artur Penttinen 2007-07-25 19:36:45 UTC
Yes, it's true :(.

The problem was in cpp, so:

# rpm -e --nodeps cpp
# yum install cpp

Tnx a lot! :)




Note You need to log in before you can comment on or make changes to this bug.