Bug 249608 - i18n warnings
i18n warnings
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-25 14:43 EDT by Piotr Drąg
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-28 07:08:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piotr Drąg 2007-07-25 14:43:56 EDT
translate.fpo shows following warning:

"There are some missing files from POTFILES.in:

    * build/rpmfc.c
    * lib/rpmlock.c
    * lib/setfiles.c
    * lib/tgi.c
    * lib/trb.c
    * lib/tre.c
    * misc/error.c
    * rpmdb/sqlite.c
    * rpmio/rpmdav.c
    * rpmio/rpmlua.c
    * rpmio/tdigest.c
    * rpmio/tdir.c
    * rpmio/tfts.c
    * rpmio/tget.c
    * rpmio/tglob.c
    * rpmio/thkp.c
    * rpmio/tput.c
    * rpmio/tring.c
    * tools/dump.c
    * tools/dumpdb.c
    * tools/rpminject.c
    * tools/rpmsort.c
    * tools/rpmtool.c"

See http://translate.fedoraproject.org/module/rpm
Comment 1 Panu Matilainen 2007-07-25 15:56:00 EDT
Most of those are false positives: all the files beginning with t are just test
stuff the user will never see (they're not even built normally) and the rest are
mostly just debugging stuff which aren't really intended to be translated at
all, but a few valid cases there still.

I'll have a look + fix, thanks for pointing this out.
Comment 2 Panu Matilainen 2007-08-07 04:29:31 EDT
The relevant parts added to upstream POTFILES.in now. 

How is the missing file list scanned in translate.fpo - intltool or something
else? I'm just wondering how to best avoid the false positives from programs
that don't even get built normally. I could of course strip out all the
translation markers from the test programs but seems like more effort than it's
worth.
Comment 3 Piotr Drąg 2007-08-08 02:36:39 EDT
I think Dimitris Glezos will be able to answer your question. Adding to CC.
Comment 4 Panu Matilainen 2007-08-28 07:08:32 EDT
rpm 4.4.2.2(-rc1) in next rawhide push includes the POTFILES.in fixes...

Note You need to log in before you can comment on or make changes to this bug.