Bug 24964 - db3/db.h configure and build out of sync
Summary: db3/db.h configure and build out of sync
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-25 21:21 UTC by eric.b.lemings
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-25 21:21:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description eric.b.lemings 2001-01-25 21:21:25 UTC
While configuring RPM, the configure script output the following:

	checking for db3/db.h... no

While compiling lib/db3.c, gcc gave the following error:

	db3.c:12: db3/db.h: No such file or directory

The db3.c source file does not even check the HAVE_DB3_DB_H config macro
nor does it even include the "config.h" header.

Comment 1 Jeff Johnson 2001-01-25 22:15:41 UTC
There are separate test for db3/db.h and lib/db3.c inclusion in rpmlib, so
there's
little reason conditionalize including db3/db.h with Yet Another Define.

Comment 2 eric.b.lemings 2001-01-25 22:39:18 UTC
I did a configure and a make and the make failed because it tried to include a
header that configure plainly determined that the header was not present.  Now
whether the source file was not supposed to be compiled in the first place or
the header file should be conditionally included is a bug.


Note You need to log in before you can comment on or make changes to this bug.