Bug 249644 - fc-cache does not cache newly installed fonts if /usr/share/fonts has newer modtime
Summary: fc-cache does not cache newly installed fonts if /usr/share/fonts has newer m...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: fontconfig   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: i18n, MoveUpstream, Reopened
Depends On:
Blocks: 249646
TreeView+ depends on / blocked
 
Reported: 2007-07-26 01:08 UTC by Caius Chance
Modified: 2008-03-05 04:01 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-05 04:01:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 12107 None None None Never

Description Caius Chance 2007-07-26 01:08:17 UTC
Description of problem:
fc-cache is not always caching newly installed fonts in fonts-chinese.

Version-Release number of selected component (if applicable):
fonts-chinese-3.03-4

How reproducible:
Sometimes.

Steps to Reproduce:
1.Fresh install Fedora 7 without Chinese support.
2.Install fonts-chinese: rpm -ivvh fonts-chinese-3.03-4.f7.rpm > rpm_inst_log
3.fc-list | sort > fc-list_out
  
Actual results:
- rpm_inst_log shows fc-cache had been run.
- fc-list_out doesn't show all installed fonts: ShanHeiSun, ZenKai.

Expected results:
- rpm_inst_log shows fc-cache had been run.
- fc-list_out shows all installed fonts: ShanHeiSun, ZenKai.

Additional info:

Comment 1 Caius Chance 2007-07-27 01:31:25 UTC
Refactorized and built:

http://koji.fedoraproject.org/koji/buildinfo?buildID=12013

Comment 2 Jens Petersen 2007-09-05 01:40:50 UTC
Moving to fontconfig since this is a general issue and not specific to
fonts-chinese.

Comment 3 Jens Petersen 2007-10-24 04:35:40 UTC
Behdad suggests it would be good to discuss this on the upstream mailing-list.

Comment 4 Peng Huang 2007-10-25 02:51:13 UTC
I discussed this problem in upstream mailing-list. It have been fixed in
upstream's source repository.


Comment 5 Jens Petersen 2008-02-07 03:02:24 UTC
fontconfig-2.5.0 has been in rawhide for a good while now,
so guess this can be closed.


Note You need to log in before you can comment on or make changes to this bug.