Bug 249658 - system-config-printer causes traceback on wrong configured printer
system-config-printer causes traceback on wrong configured printer
Status: CLOSED DUPLICATE of bug 207965
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-printer (Show other bugs)
4.5
All Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-26 04:34 EDT by Michal Nowak
Modified: 2013-03-07 21:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-27 05:12:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Nowak 2007-07-26 04:34:04 EDT
Description of problem:
system-config-printer causes traceback on wrong configured printer.

Version-Release number of selected component (if applicable):
foomatic-3.0.2-3
system-config-printer-0.6.116.10-1
foomatic-3.0.2-3.1

How reproducible:
Always

Steps to Reproduce:
Use system-config-printer-0.6.116.10-1 and foomatic-3.0.2-3

1. Import the PPD from
http://www.linuxprinting.org/download/oldPPDs/HP/mono_laser/HP_LaserJet_8100_Series.ppd
2. Create a new printer using the imported PPD as driver
3. Select "Edit" from context menu in printer list

it will cause a traceback (as in bug #207965).

Then upgrade to foomatic-3.0.2-3.1. Start system-config-printer, hit "Edit"
button and it will cause a traceback too. 

When creating new printer from imported PPD (with new foomatic) and then hitting
"Edit" - no traceback occurs. 

Actual results:

Traceback -

Couldn't load driver information.Traceback (most recent call last):
  File "/usr/share/printconf/util/queueTree.py", line 599, in
edit_button_clicked
    if self.editQueue.editQueueDialog (iter):
  File "/usr/share/printconf/util/editQueue.py", line 414, in
editQueueDialog
    self.write_driver_options ()
  File "/usr/share/printconf/util/editQueue.py", line 919, in
write_driver_options
    for option_tuple in option_list:
TypeError: iteration over non-sequence

Expected results:
A window with editable options should pop up
Comment 1 Tim Waugh 2007-07-27 05:12:14 EDT

*** This bug has been marked as a duplicate of 207965 ***
Comment 2 Tim Waugh 2007-07-31 09:29:39 EDT
FWIW, util/editQueue.py:919 does *not* read:

  for option_tuple in option_list:

in 0.6.116.10-1, so that traceback did not come from this version.

Note You need to log in before you can comment on or make changes to this bug.