Bug 249687 - crash in efhd_attachment_button on a mail I received, workaround attached
Summary: crash in efhd_attachment_button on a mail I received, workaround attached
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-26 13:57 UTC by Caolan McNamara
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-18 13:02:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
workaround (597 bytes, patch)
2007-07-26 13:57 UTC, Caolan McNamara
no flags Details | Diff

Description Caolan McNamara 2007-07-26 13:57:49 UTC
I got this crash on loading a mail I received with a html attachment, patch
attached to workaround

#0  0x00000039cec3741d in g_logv () from /lib64/libglib-2.0.so.0
#1  0x00000039cec375d3 in g_log () from /lib64/libglib-2.0.so.0
#2  0x00000039cec37656 in g_assert_warning () from /lib64/libglib-2.0.so.0
#3  0x00002aaab2ef0f37 in efhd_attachment_button (efh=0xa5b150, eb=0xc98bd0,
pobject=0x1460e80)
    at em-format-html-display.c:1783
#4  0x00002aaab2ef1d5e in efh_object_requested (html=<value optimized out>,
eb=0xc98bd0, efh=0xa5b150) at em-format-html.c:615
#5  0x0000003e4a66c0ed in html_g_cclosure_marshal_BOOLEAN__OBJECT () from
/usr/lib64/libgtkhtml-3.14.so.19
#6  0x00000039cf00b14a in g_closure_invoke () from /lib64/libgobject-2.0.so.0
#7  0x00000039cf01bbd7 in ?? () from /lib64/libgobject-2.0.so.0
#8  0x00000039cf01ce28 in g_signal_emit_valist () from /lib64/libgobject-2.0.so.0
#9  0x00000039cf01d243 in g_signal_emit () from /lib64/libgobject-2.0.so.0
#10 0x0000003e4a63064e in ?? () from /usr/lib64/libgtkhtml-3.14.so.19
#11 0x0000003e4a66c0ed in html_g_cclosure_marshal_BOOLEAN__OBJECT () from
/usr/lib64/libgtkhtml-3.14.so.19
#12 0x00000039cf00b14a in g_closure_invoke () from /lib64/libgobject-2.0.so.0
#13 0x00000039cf01bbd7 in ?? () from /lib64/libgobject-2.0.so.0
#14 0x00000039cf01ce28 in g_signal_emit_valist () from /lib64/libgobject-2.0.so.0
#15 0x00000039cf01d243 in g_signal_emit () from /lib64/libgobject-2.0.so.0
#16 0x0000003e4a65c3ef in ?? () from /usr/lib64/libgtkhtml-3.14.so.19
#17 0x0000003e4a65acb0 in ?? () from /usr/lib64/libgtkhtml-3.14.so.19
#18 0x0000003e4a66085d in ?? () from /usr/lib64/libgtkhtml-3.14.so.19
#19 0x0000003e4a660908 in html_engine_flush () from /usr/lib64/libgtkhtml-3.14.so.19
#20 0x00002aaab2ef8689 in emhs_sync_flush (stream=<value optimized out>) at
em-html-stream.c:127
#21 0x00002aaab2f053d0 in emss_process_message (msg=0x44605f40) at
em-sync-stream.c:80
#22 0x00000039cec2ef13 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#23 0x00000039cec3220d in ?? () from /lib64/libglib-2.0.so.0
#24 0x00000039cec3251a in g_main_loop_run () from /lib64/libglib-2.0.so.0
#25 0x00000039dd62cdb6 in bonobo_main () from /usr/lib64/libbonobo-2.so.0
#26 0x0000000000417d72 in main (argc=1, argv=<value optimized out>) at main.c:593

Comment 1 Caolan McNamara 2007-07-26 13:57:49 UTC
Created attachment 160017 [details]
workaround

Comment 3 Milan Crha 2007-10-18 12:41:57 UTC
Can you try this on actual rawhide, please? The fix from upstream bug is there
since Evolution 2.12.0-1.fc8. Thanks in advance.

Comment 4 Caolan McNamara 2007-10-18 13:02:05 UTC
Lets just assume it works, I don't have the mail anymore.


Note You need to log in before you can comment on or make changes to this bug.