Bug 249702 - pkcs11-tool segfaults when run
pkcs11-tool segfaults when run
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: opensc (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-26 11:13 EDT by Nalin Dahyabhai
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 0.11.3-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-26 15:11:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nalin Dahyabhai 2007-07-26 11:13:27 EDT
Description of problem:
If I run pkcs11-tool with no arguments, it crashes.

Version-Release number of selected component (if applicable):
opensc-0.11.3-1.fc8

Here's the backtrace from the core dump:
#0  0x00002aaaabd96160 in strlen () from /lib64/libc.so.6
(gdb) where
#0  0x00002aaaabd96160 in strlen () from /lib64/libc.so.6
#1  0x00002aaaabd650bb in vfprintf () from /lib64/libc.so.6
#2  0x00002aaaabe033a1 in __printf_chk () from /lib64/libc.so.6
#3  0x000000000040a651 in print_usage_and_die (app_name=<value optimized out>, 
    options=0x40f0a0, option_help=0x610620) at util.c:187
#4  0x0000000000409427 in main (argc=1, argv=0x7fff3b766c08)
    at pkcs11-tool.c:451
#5  0x00002aaaabd3cab4 in __libc_start_main () from /lib64/libc.so.6
#6  0x0000000000401e69 in _start ()
Comment 1 Ville Skyttä 2007-07-26 15:11:45 EDT
Yep, usage message output crash caused by a missing description for the
--delete-object option.  Fixed in 0.11.3-2 which is currently being built,
thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.