This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 249742 - debuginfo-install cryptsetup-luks crashes with keyerror
debuginfo-install cryptsetup-luks crashes with keyerror
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-26 15:03 EDT by Till Maas
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.1.8-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-26 13:46:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Till Maas 2007-07-26 15:03:03 EDT
Description of problem:
When I run "debuginfo-install cryptsetup-luks" there is an keyerror and the
program terminates.

Version-Release number of selected component (if applicable):
1.1.5-1

How reproducible:
always

Steps to Reproduce:
1.run debuginfo-install cryptsetup-luks
  
Actual results:
# debuginfo-install cryptsetup-luks
Loading "priorities" plugin
Loading "skip-broken" plugin
Loading "installonlyn" plugin
Loading "protectbase" plugin
enabling livna-debuginfo
Reading repository metadata in from local files
Traceback (most recent call last):
  File "/usr/bin/debuginfo-install", line 105, in <module>
    util = DebugInfoInstall()
  File "/usr/bin/debuginfo-install", line 38, in __init__
    self.main()
  File "/usr/bin/debuginfo-install", line 56, in main
    self.doRepoSetup(thisrepo=r.id)
  File "/usr/share/yum-cli/cli.py", line 114, in doRepoSetup
    self._getSacks(thisrepo=thisrepo)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 370, in _getSacks
    self.plugins.run('exclude')
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 164, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/priorities.py", line 74, in exclude_hook
    repopkgs = _pkglisttodict(conduit.getPackages(repo), repo.priority)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 494, in getPackages
    return self._base.pkgSack.returnPackages(arg)
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 298, in
returnPackages
    return self.sacks[repoid].returnPackages()
KeyError: 'adobe-linux'

Expected results:
I guess it should install the debuginfo rpm of cryptsetup-luks.

Additional info:
Do you need my repo configuration or something else?
Comment 1 Seth Vidal 2007-07-26 15:06:58 EDT
please disable priorities plugin and try again.

Comment 2 Till Maas 2007-07-26 15:36:04 EDT
Without the priorities plugin the KeyError changed to:
KeyError: 'fedora'
Comment 3 Seth Vidal 2007-07-26 18:18:37 EDT
okay - but did everything else stay the same?

also which version of yum is this?
Comment 4 Till Maas 2007-07-26 18:51:56 EDT
I just noticed that there is also a change in one line number:
I did not see this earlier, because I first tried to disable the plugin with
"--disableplugin=priorities", which seems not to work and then disabled the
plugin in /etc/yum/pluginconf.d. Is it known that "--disableplugin" does not
work? Otherwise I will open another bug report. 
yum version: yum-3.2.1-1.fc7


--- debug-priorities    2007-07-27 00:41:13.824387753 +0200
+++ debug-no-priorities      2007-07-27 00:43:16.324770528 +0200
@@ -1,4 +1,3 @@
-Loading "priorities" plugin
 Loading "skip-broken" plugin
 Loading "installonlyn" plugin
 Loading "protectbase" plugin
@@ -17,10 +16,10 @@
     self.plugins.run('exclude')
   File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 164, in run
     func(conduitcls(self, self.base, conf, **kwargs))
-  File "/usr/lib/yum-plugins/priorities.py", line 74, in exclude_hook
-    repopkgs = _pkglisttodict(conduit.getPackages(repo), repo.priority)
+  File "/usr/lib/yum-plugins/protectbase.py", line 51, in exclude_hook
+    repo1pkgs = _pkglisttodict(conduit.getPackages(repo1))
   File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 494, in getPackages
     return self._base.pkgSack.returnPackages(arg)
   File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 298, in
returnPackages
     return self.sacks[repoid].returnPackages()
-KeyError: 'adobe-linux'
+KeyError: 'fedora'
Comment 5 Seth Vidal 2007-07-26 19:36:30 EDT
wow, a diff of a traceback. okay - first and foremost:
upgrade to yum 3.2.2, please. I just want to make sure that's not it.

thanks
Comment 6 Till Maas 2007-07-27 03:49:56 EDT
With yum-3.2.2-1.fc7 from updates-testing some line numbers change again:

--- debug-no-priorities      2007-07-27 00:43:16.324770528 +0200
+++ debug-new-yum-no-priorities     2007-07-27 09:48:01.744844303 +0200
@@ -1,5 +1,4 @@
 Loading "skip-broken" plugin
-Loading "installonlyn" plugin
 Loading "protectbase" plugin
 enabling livna-debuginfo
 Reading repository metadata in from local files
@@ -10,9 +9,9 @@
     self.main()
   File "/usr/bin/debuginfo-install", line 56, in main
     self.doRepoSetup(thisrepo=r.id)
-  File "/usr/share/yum-cli/cli.py", line 114, in doRepoSetup
+  File "/usr/share/yum-cli/cli.py", line 115, in doRepoSetup
     self._getSacks(thisrepo=thisrepo)
-  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 370, in _getSacks
+  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 381, in _getSacks
     self.plugins.run('exclude')
   File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 164, in run
     func(conduitcls(self, self.base, conf, **kwargs))
Comment 7 Tim Lauridsen 2007-09-28 09:24:45 EDT
Please retest with latest yum-utils & yum.
debuginfo-install cryptsetup-luks
works for me with yum-utils-1.17 & yum-3.2.5.
Comment 8 Till Maas 2007-09-28 09:35:50 EDT
It does still not work:

# debuginfo-install cryptsetup-luks
Loading "skip-broken" plugin
Loading "protectbase" plugin
enabling livna-debuginfo
Reading repository metadata in from local files
Traceback (most recent call last):
  File "/usr/bin/debuginfo-install", line 106, in <module>
    util = DebugInfoInstall()
  File "/usr/bin/debuginfo-install", line 38, in __init__
    self.main()
  File "/usr/bin/debuginfo-install", line 56, in main
    self.doRepoSetup(thisrepo=r.id)
  File "/usr/share/yum-cli/cli.py", line 116, in doRepoSetup
    self._getSacks(thisrepo=thisrepo)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 392, in _getSacks
    self.plugins.run('exclude')
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 169, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/protectbase.py", line 51, in exclude_hook
    repo1pkgs = _pkglisttodict(conduit.getPackages(repo1))
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 499, in getPackages
    return self._base.pkgSack.returnPackages(arg)
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 304, in
returnPackages
    return self.sacks[repoid].returnPackages()
KeyError: 'fedora'

yum-utils-1.1.7-1.fc7
yum-3.2.5-1.fc7

With yum-priorites the error still differs.
Comment 9 Tim Lauridsen 2007-09-28 11:00:13 EDT
What about
debuginfo-install --noplugins cryptsetup-luks


Comment 10 Till Maas 2007-09-28 11:09:40 EDT
(In reply to comment #9)
> What about
> debuginfo-install --noplugins cryptsetup-luks

Thank you very much, this works.
Comment 11 Tim Lauridsen 2007-09-28 12:15:48 EDT
Ok, i have found the bug in debug-install, there make it break with some plugins
like protectbase.

Fixed upstream:
http://devel.linux.duke.edu/gitweb/?p=yum-utils.git;a=blob_plain;f=debuginfo-install.py;hb=HEAD
Comment 12 Fedora Update System 2007-10-24 03:03:51 EDT
yum-utils-1.1.8-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum-utils'
Comment 13 Fedora Update System 2007-11-26 13:46:17 EST
yum-utils-1.1.8-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.