Bug 249757 - Extremely sluggish performance with Core 2 Quad CPU on all fc5 smp kernels (2.6.15-1.2054_FC5smp through 2.6.20-1.2320.fc5smp)
Extremely sluggish performance with Core 2 Quad CPU on all fc5 smp kernels (2...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-26 16:27 EDT by Noah Sheppard
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-26 16:45:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noah Sheppard 2007-07-26 16:27:01 EDT
Description of problem:
We have two machines built with MSI P6N SLI motherboards, 4GB RAM, and Core 2
Quad processors.  When booted with any kernel-smp in fc5, these systems run
extremely sluggishly, with symptoms like:
-udev times out
-booting and getting to runlevel 5 takes about 15 minutes
-response to commands is very slow
-X11 is essentially unusable (when the background changes color, like during
login, you can watch the color paint down the screen)
-logging in via SSH over our LAN takes ~15 seconds
-dd if=/dev/zero of=./test.bin writes at 3.1 MB/s under an fc5 smp kernel,
versus 88.6 MB/s on a custom compiled smp kernel

Uniprocessor kernels run fine, but of course only detect a single core, which
isn't really a good solution given the price we paid for these CPUs :).  Also,
if I build my own kernels from scratch with vanilla sources and WITH smp
support, everything runs great, all four cores are detected, the system is
really fast.  Knoppix and Ubuntu smp kernels also run fine.

The fact that UP fc5 kernels and custom or other distro smp kernels run fine
makes me sure that:
1-This not a problem with smp support in the Linux kernel in general.
2-This is not a problem with our specific combination of motherboard, CPU, RAM
unless there is some obscure option or patch in the fc5 smp kernels which other
distros don't use and happens to not like our hardware.

Although we want to build this system 32 bit, I did try running the Fedora 7
x86_64 installer DVD, and the kernel on this DVD also behaved with the exact
same sluggishness (correct me if I'm wrong, but I think the x86_64 kernels are
compiled with smp support, so smp support is still the common theme).

I've looked through /var/log/messages and not found anything that seems to be
relevant to this, as technically nothing is really crashing or erroring out
(except udev because it times out), it's just all running as if time had been
slowed down.  Please let me know if you would like any log files.  I have a good
bit of kernel building experience, but little in the way of kernel debugging, so
I'm not quite sure what to give you.

As far as kernel boot options, nothing was customized, they just booted with the
standard arguments: ro root=LABEL=/ rhgb quiet.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.15-1.2054_FC5
kernel-smp-2.6.20-1.2316.fc5
kernel-smp-2.6.20-1.2320.fc5
the kernel on the f7 installer DVD

How reproducible:
Try to run an fc5 kernel-smp on a Core 2 Quad system.

Steps to Reproduce:
1. Build a system with a Core 2 Quad processor.
2. Install fc5 i386 (the installer will install an smp kernel).
3. Reboot the system.

Expected result:
The system is extremely sluggish.

Actual result:
The system is extremely sluggish.

Thanks for your help.
Comment 1 Jarod Wilson 2007-07-26 16:45:35 EDT
FC5 is no longer supported, there will be no further updates released for it.
For what its worth, the FC6 and F7 kernels work quite nicely on my own core 2
quad system (typing on it composing this entry). Nb: there's no more separate
smp kernel in FC6 and later, except on 32-bit powerpc.

Note You need to log in before you can comment on or make changes to this bug.