Bug 249758 - locking in 5.1 breaks rgmanager
locking in 5.1 breaks rgmanager
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rgmanager (Show other bugs)
5.1
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Lon Hohberger
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-26 16:27 EDT by Lon Hohberger
Modified: 2009-04-16 18:18 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0580
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 11:46:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Fix (482 bytes, patch)
2007-07-26 16:27 EDT, Lon Hohberger
no flags Details | Diff
Smaller patch. (449 bytes, patch)
2007-07-26 16:30 EDT, Lon Hohberger
no flags Details | Diff

  None (edit)
Description Lon Hohberger 2007-07-26 16:27:19 EDT
Description of problem:

The changes to libdlm from 5.0->5.1 break rgmanager.  This is most likely due to
rgmanager relying on a particular errant behavior in libdlm (where either
dlm_dispatch or dlm_ls_lock would return -1 on convert w/ no-queue).

The correction is to simply have rgmanager always look at the lock status prior
to accepting a lock grant.

This is easily reproducible with the locktest program in src/clulib.

Version-Release number of selected component (if applicable): 5.1 beta

How reproducible: 100%

Steps to Reproduce:
1. run locktest on one node
2. run locktest on another node
  
Actual results: Both locktest acquire an EX lock, or appear to.

Expected results: One locktest acquires an EX lock; the other hangs.

Additional info:
Comment 1 Lon Hohberger 2007-07-26 16:27:19 EDT
Created attachment 160070 [details]
Fix
Comment 2 Lon Hohberger 2007-07-26 16:30:08 EDT
Created attachment 160071 [details]
Smaller patch.
Comment 3 Lon Hohberger 2007-07-26 16:49:15 EDT
Patch in head RHEL51 RHEL5
Comment 7 errata-xmlrpc 2007-11-07 11:46:25 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0580.html

Note You need to log in before you can comment on or make changes to this bug.