Bug 249786 - ksynaptics 0.3.3
ksynaptics 0.3.3
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ksynaptics (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
http://qsynaptics.sourceforge.net/ind...
:
Depends On: 249787
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-26 20:23 EDT by Douglas E. Warner
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 0.3.3-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-24 01:40:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file (73.72 KB, text/plain)
2007-08-14 21:05 EDT, Douglas E. Warner
no flags Details

  None (edit)
Description Douglas E. Warner 2007-07-26 20:23:33 EDT
Description of problem:
ksynaptics constantly displays the error
"Shared Memory is not accessible.
Please add the option 'UseShm ''true''' into the touch pad section 
of /etc/X11/xorg.conf"

This is supposedly fixed in 0.3.3.

libsynaptics 0.14.6c is also required.
Comment 1 Fedora Update System 2007-08-08 11:27:42 EDT
ksynaptics-0.3.3-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 2 Orion Poplawski 2007-08-08 19:03:49 EDT
Let me know if this fixes the problem and doesn't cause any other issues.
Comment 3 Douglas E. Warner 2007-08-13 14:35:44 EDT
I'm still having problems using ksynaptics (or any other synaptics frontend) 
with a similar error:

"Shared Memory is not accessible.
Please add the option 'SHMConfig ''on''' into the touch pad section 
of /etc/X11/xorg.conf"

Below is my xorg.conf file snippet.

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "synaptics"
        Option      "Device" "/dev/input/mice"
        Option      "Protocol" "auto-dev"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "yes"
        Option      "LeftEdge" "1970"
        Option      "RightEdge" "5300"
        Option      "TopEdge" "1700"
        Option      "BottomEdge" "4200"
        Option      "FingerLow" "25"
        Option      "FingerHigh" "30"
        Option      "MaxTapTime" "180"
        Option      "MaxTapMove" "220"
        Option      "VertScrollDelta" "100"
        Option      "MinSpeed" "0.09"
        Option      "MaxSpeed" "0.18"
        Option      "AccelFactor" "0.0015"
        Option      "SHMConfig" "On"
EndSection
Comment 4 Orion Poplawski 2007-08-14 18:22:35 EDT
Well, works for me.  Can you attach your /var/log/Xorg.0.log file?  You aren't
trying to access while the machine is in a dock are you?
Comment 5 Douglas E. Warner 2007-08-14 21:04:35 EDT
(In reply to comment #4)
> Well, works for me.  Can you attach your /var/log/Xorg.0.log file?  You 
aren't
> trying to access while the machine is in a dock are you?

I tried accessing it while it was in a dock and while undocked, actually.
Comment 6 Douglas E. Warner 2007-08-14 21:05:43 EDT
Created attachment 161320 [details]
Xorg log file
Comment 7 Orion Poplawski 2007-08-14 23:55:17 EDT
Can you attach your full xorg.conf file?  Looks like the driver really isn't
being initialized.  Be sure you have:

        InputDevice    "Mouse0" "AlwaysCore"

in your ServerLayout section as well.

On my machine the synaptics device is disabled while in a dock.
Comment 8 Douglas E. Warner 2007-08-21 09:22:43 EDT
(In reply to comment #7)
> Be sure you have:
> 
>         InputDevice    "Mouse0" "AlwaysCore"
> 
> in your ServerLayout section as well.

This is apparently the line I was missing in my xorg.conf file.  Everything 
seems to be working now.  Thanks for your help!
Comment 9 Fedora Update System 2007-08-24 01:40:00 EDT
ksynaptics-0.3.3-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.