Bug 249797 - yum-presto: variable expansion fails
yum-presto: variable expansion fails
Product: Fedora
Classification: Fedora
Component: yum-presto (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Jonathan Dieter
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-07-26 22:43 EDT by Rex Dieter
Modified: 2014-01-21 17:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-07-30 15:31:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2007-07-26 22:43:54 EDT
For a private repo of mine, I've always pointed yum to a mirror list, something
like, say:

Which contains entries that contain/use variables ($releasever, $arch), ie,

Using yum-3.2.2-1.fc7, this no longer works, yum tries to use
which, of course, doesn't work.
Comment 1 Rex Dieter 2007-07-27 08:04:31 EDT
OK, totally creepy.  Tried duplicating this on another f7 box this morning, and
couldn't.  it works.  box boxes have updates-testing enabled.
Comment 2 Rex Dieter 2007-07-27 08:10:45 EDT
on the box that fails, it's not just the mirrorlist, substituting
fails too, with
Error: Cannot open/read repodata/repomd.xml file ...

Comment 3 Rex Dieter 2007-07-27 08:33:40 EDT
Arg, cast the gremlins away!

I just changed to 
to verify my sanity (and it works), changed back to
and now that works too! ??  It didn't just minutes before. (I run 'rm -rf
/var/cache/yum/*' in between invocations for extra paranoia).

So trying,
but that (still) failed. ):

On a whim, tried disabling yum-presto, bingo! fixed!.  reassigning.

$ rpm -q yum-presto

Comment 4 Jonathan Dieter 2007-07-30 15:31:18 EDT
This bug shouldn't exist in yum-presto 0.4.0 (the version in Rawhide that's been
pretty much rewritten).

Yum-presto 0.3.x re-used some older yum code that didn't properly parse mirrorlists.

I'm going to close this as Rawhide, but if you want me to fix it in F7 (which
isn't trivial), please re-open the bug.

Note You need to log in before you can comment on or make changes to this bug.