Bug 249812 - missing headers
missing headers
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: blt (Show other bugs)
6
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Jean-Luc Fontaine
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 352761
  Show dependency treegraph
 
Reported: 2007-07-27 04:42 EDT by Chitlesh GOORAH
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.4-19.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-26 13:36:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chitlesh GOORAH 2007-07-27 04:42:09 EDT
Description of problem:
the blt shipped by fc6 and onwards (since there were no changes) lacks headers 
such as blt.h needed by many other applications.

tclspice requires it.
even some users needed to get their hands dirty to have those headers.
http://www.omnetpp.org/listarchive/msg09170.php

Version-Release number of selected component (if applicable):
blt-2.4-14.z.fc6


Actual results:
no headers available for download

Expected results:
headers should be shipped

Additional info:
http://cvs.mandriva.com/cgi-bin/viewvc.cgi/SPECS/blt/blt.spec?view=markup
Comment 1 Chitlesh GOORAH 2007-08-05 19:49:28 EDT
ping ?
the bug is preventing from submitting the tclspice package for review !
Comment 2 Chitlesh GOORAH 2007-08-14 17:53:24 EDT
ping ?
the bug is preventing from submitting the tclspice package for review !

You are NOT responsible at all !
Comment 3 Sergio Pascual 2007-10-12 12:11:12 EDT
The headers are needed to build ds9
Comment 4 Marek Mahut 2007-10-22 12:16:58 EDT
Please, resolve this bug as soon as possible.
Comment 5 Marek Mahut 2007-10-23 05:56:34 EDT
Nevermind, we need these files for D9 build and few other as I can see, I'm
going to build it.
Comment 6 Marek Mahut 2007-10-23 06:18:26 EDT
Build in rawhide. Proposed as update for F-7 and F-8.
Comment 7 Mamoru TASAKA 2007-10-23 06:37:45 EDT
I cannot understand the situation.

As current blt does not provide any libraries under %_libdir,
why does it the solution to you to provide only header files under
%_includedir? Usually only providing header files under %_includedir
is useless, as we cannot know what libraries provide the symbols
written in the header files.
Comment 8 Sergio Pascual 2007-10-23 06:59:01 EDT
There are two libraries: /usr/lib*/blt2.4/libBLT24.so and
/usr/lib*/blt2.4/libBLTlite24.so
Comment 9 Mamoru TASAKA 2007-10-23 07:10:18 EDT
(In reply to comment #8)
> There are two libraries: /usr/lib*/blt2.4/libBLT24.so and
> /usr/lib*/blt2.4/libBLTlite24.so

I know them, however they
- are not under %_libdir (ldconfig default path), and
  blt does not provide ld.so.conf.d file, so these libraries cannot
  be used unless rpath option is passed when using ld (like
  firefox)
- don't have soname. This is very troublesome because it can be
  that ABI can change without any name change, which will cause
  all binaries linked with these libraries useless silently.
Comment 10 Sergio Pascual 2007-10-23 07:23:48 EDT
(In reply to comment #9)
> I know them, however they
> - are not under %_libdir (ldconfig default path), and
>   blt does not provide ld.so.conf.d file, so these libraries cannot
>   be used unless rpath option is passed when using ld (like
>   firefox)

There is a bug about that: https://bugzilla.redhat.com/show_bug.cgi?id=333081


> - don't have soname. This is very troublesome because it can be
>   that ABI can change without any name change, which will cause
>   all binaries linked with these libraries useless silently.

Comment 11 Mamoru TASAKA 2007-10-23 07:41:35 EDT
Still "no soname" problem remains even if ld.so.conf.d problem
is resolved.
Comment 12 Mamoru TASAKA 2007-10-23 08:51:52 EDT
(In reply to comment #11)
> Still "no soname" problem remains even if ld.so.conf.d problem
> is resolved.

Ah... as the names of the libraries have version (24), "no soname"
problem can perhaps be ignored.
Comment 13 Fedora Update System 2007-11-06 11:13:43 EST
blt-2.4-18.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update blt'
Comment 14 Fedora Update System 2007-11-06 11:16:25 EST
blt-2.4-17.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update blt'
Comment 15 Marek Mahut 2007-11-09 03:03:48 EST
Build blt-2.4-18 correcting Bugzilla Bug 333081 is also available. Closing this
bug as resolved. Maybe someone should take over this package as the maintainer
isn't a responsible person?
Comment 16 Fedora Update System 2007-11-09 18:43:00 EST
blt-2.4-17.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2007-11-09 18:43:06 EST
blt-2.4-17.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update blt'
Comment 18 Fedora Update System 2007-11-09 18:58:15 EST
blt-2.4-18.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update blt'
Comment 19 Fedora Update System 2007-11-12 18:58:07 EST
blt-2.4-17.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2007-11-15 19:38:03 EST
blt-2.4-19.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update blt'
Comment 21 Fedora Update System 2007-11-15 19:39:06 EST
blt-2.4-19.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update blt'
Comment 22 Fedora Update System 2007-11-26 13:36:30 EST
blt-2.4-19.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 23 Fedora Update System 2007-11-26 13:41:34 EST
blt-2.4-19.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.