Bug 249823 - p54pci driver has stopped working
p54pci driver has stopped working
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
http://marc.info/?l=linux-wireless&m=...
: Patch, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-27 06:57 EDT by Hans de Goede
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-29 04:15:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2007-07-27 06:57:05 EDT
The Fedora 7 gold kernel (I haven't checked the updates) included a patch to
update the upstream kernel to the latest wireless-dev tree, this included the
prims54pci driver, which is a version of the islsm driver ported to devicescape.

I own a prism softmac card, and was happily using it with the Fedora 7 test
kernels (it worked fine), since the involved laptop is running rawhide I updated
it yesterday (which was about time it was still on circa Fedora 7 test4), and
then noticed that the new kernel no longer includes the prism54pci driver needed
for my card :(

Any chance this driver can be added back to the Fedora kernel? If not that would
be an unfortunate regression for me, and I'm sure for others too.
Comment 1 John W. Linville 2007-07-27 10:23:05 EDT
Look for "p54pci" -- the driver got renamed in wireless-dev.  I added a 
MODULE_ALIAS line.  Perhaps that is insufficient to avoid this -- I thought 
that was what it was for?

Anyway, I presume the p54pci works alright for you?
Comment 2 Hans de Goede 2007-07-27 11:56:51 EDT
I read somewhere about the rename and already tried a modprobe p54pci, no joy, 
on my laptop neither module is there:
[hans@localhost ~]$ cd /lib/modules/2.6.23-0.43.rc0.git16.fc8/
[hans@localhost 2.6.23-0.43.rc0.git16.fc8]$ find -name p54pci.ko
[hans@localhost 2.6.23-0.43.rc0.git16.fc8]$ find -name prism54pci.ko
[hans@localhost 2.6.23-0.43.rc0.git16.fc8]$

There isn't even a mac80211 directory under kernel/drivers/net/wireless

Hmm, maybe I just hit a bad kernel? Updating to the latest ... installed
2.6.23-0.49.rc1.git3.fc8 ... which does include the driver ... but doesn't work.

It associates and iwlist scan-s perfect, but it doesn't seem to send or receive
any data, dhclient doesn't work nor pinging after manual ifconfig :(

Shall I change the summary or do you want me to open a new bug for this?



Comment 3 Hans de Goede 2007-07-27 16:09:06 EDT
Okay, recycling the bug. I've been busy researching this and I have come to the
following conclusions.

1) with the 2.6.20-2something F7-test kernel everything works fine build date
   3 march, I can give you the exact revision if you want.

2) with the fc release kerkel (3194) things work, but the connection is often lost.

3) with the 2.6.23-0.49.rc1.git3.fc8, the card asociates and thats it.

Using wireless git and out of tree driver building I've found that the following
2 patches are the culprits:

Patch causing loose off connection within seconds when fully loading the link
with a local file transfer:
http://bu3sch.de/gitweb?p=wireless-dev.git;a=commitdiff;h=62ee473d67b7ae353d210b186abaadc37a642237

Only associating and nothing else:
http://bu3sch.de/gitweb?p=wireless-dev.git;a=commitdiff;h=7d59453a9dbe50dc9bab846c410e39f8d5b10c83
And then specifically the changes to prism54common.c

This is with an isl3886 cardbus card, using the p54pci driver. I think this is
probably best handled upstream, if you agree just me let me know who's door to
knock on / which mailinglist to join and start complaining on.
Comment 4 Hans de Goede 2007-08-12 16:10:33 EDT
Linville,

I've spend a lot of time finding out exactly which changes in the p54pci driver
have caused my regressions, some attention for this bug would be nice.

Even if its just telling me the email of someone upstream to further discuss
this with.
Comment 5 John W. Linville 2007-08-12 19:13:16 EDT
I'm terribly sorry, Hans!  Busy, busy...I'm sure you understand.

I think you should open a thread on linux-wireless@vger.kernel.org, and be 
sure to CC: Michael Wu <flamingice@sourmilk.net>.

Thanks!
Comment 6 Hans de Goede 2007-08-13 01:52:21 EDT
Thanks, mail send upstream, closing this with a resolution of upstream.
Comment 7 Nils Philippsen 2007-09-03 18:34:32 EDT
Thanks to Hans and various other people upstream, there are two patches which
worked wonderfully(*) for me when applied to the current F-7 kernel source.

(*): "wonderfully" as in "still occasionally loses link, but gets it back
quickly". Hans, perhaps you can check this against the different versions you have?

The relevant posting on linux-wireless can be found at:
http://marc.info/?l=linux-wireless&m=118833057313088&w=2

The patches are:

p54-pull-padding2.diff: http://marc.info/?l=linux-wireless&m=118833057313088&q=p3

p54-support-older-firmwares.diff
http://marc.info/?l=linux-wireless&m=118833057313088&q=p4

They need to be applied in this order and have done so with only slight offset
here (kernel-2.6.22.5-77.fc7). Therefore I'll reopen this one.

John, if you think waiting until upstream does this officially (do they have a
git repo available? -- didn't find one) is better, feel free to CLOSE/UPSTREAM
it again but it'd be nice to have this in the next F7 kernel update.
Comment 8 Nils Philippsen 2007-09-03 18:35:21 EDT
Sheesh, just noticed that this bug is for devel -- shall I clone this for F7?
Comment 9 John W. Linville 2007-09-10 13:31:10 EDT
I've been keeping F7 mostly up-to-date with rawhide, and both mostly 
up-to-date with what I push upstream.  So, I don't really think an F7 bug is 
necessary.
Comment 10 Nils Philippsen 2007-09-11 04:39:06 EDT
Good. Now what do you think about having the patches for the Fedora driver? I've
used a patched driver for some time now and it works rather well -- the odd
dropped link but you don't notice it unless you happen to watch the card's lights.
Comment 11 John W. Linville 2007-09-28 14:50:32 EDT
http://koji.fedoraproject.org/koji/buildinfo?buildID=19785

Please try the current rawhide kernels.  Are they working better for you?
Comment 12 Hans de Goede 2007-09-29 04:15:50 EDT
Yes things now work as well as they used to (iow they work as well as one can
expect when combining the cheapest AP on the planet with the cheapest wifi card
in a neighborhood where almost every house has an AP and the houses are build
side to side).

Closing, and thanks!
Comment 13 Nils Philippsen 2007-09-30 12:34:57 EDT
Same here with the current F7 kernel (2.6.22.7-85.fc7).

Note You need to log in before you can comment on or make changes to this bug.