Bug 249830 - share visibility problem
share visibility problem
Status: CLOSED DUPLICATE of bug 251477
Product: Fedora
Classification: Fedora
Component: system-config-samba (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-27 07:36 EDT by David Bentley
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-28 03:46:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Bentley 2007-07-27 07:36:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; BT [build 60A]; .NET CLR 1.1.4322; .NET CLR 2.0.50727)

Description of problem:
When adding a new share if you tick the visible box and exit normally then on next opeing s-c-samba there is no tick in the box and if you look at the samba.conf file the line just aded and subsequent ones if you put aq tick in the visible box ore in the conf file but are commented out which as a result makes the share invisible to a windows machine browsing for the share.

If you remove the swmi-colon in the conf file and save it then on next re-boot or by restarting samba the share becomes visible as expected.

Version-Release number of selected component (if applicable):
current as in F7 on 27/07/2007

How reproducible:
Always


Steps to Reproduce:
see above

Actual Results:
see above

Expected Results:
line added to the conf file but not commented out.

Additional info:
The non-visibility when commented out has only been seen from Windows XP.
Comment 1 David Bentley 2007-07-27 18:15:15 EDT
Having delved a little deeper it would seem that the share is always visible
despite what I said about not being visible from XP as after a re-boot of the XP
machine I coulsd see the share even though browsable = yes is commented out in
the smb.conf file.

It seems it only becomes non-browsable if you can get s-c-samba to record an un
commented out browsable = no  but every time you change the state back to
visible  with a tick in the box another commented out browsable = yes is added
to the conf file.

Also because of the commented out browsable = yes instead of just browsable =
yes the GUI tick box does not pick up the current browsable state.
Comment 2 Nils Philippsen 2007-08-28 03:46:29 EDT

*** This bug has been marked as a duplicate of 251477 ***

Note You need to log in before you can comment on or make changes to this bug.