Bug 249839 - clean-libtool insufficient with subdir-objects
Summary: clean-libtool insufficient with subdir-objects
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: automake   
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-27 12:48 UTC by Miloslav Trmač
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-14 09:42:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Reproducer (556 bytes, application/octet-stream)
2007-07-27 12:48 UTC, Miloslav Trmač
no flags Details

Description Miloslav Trmač 2007-07-27 12:48:14 UTC
Description of problem:
(make distclean) leaves a libtool temporary subdirectory around if
subdir-objects are used.

Version-Release number of selected component (if applicable):
autoconf-2.61-8.fc7
automake-1.10-5
libtool-1.5.22-11.fc7

Steps to Reproduce:
1. extract the attached tarball
2. autoreconf -is && ./configure && make
3. make distclean
  
Actual results:
.src/libs was not removed

Comment 1 Miloslav Trmač 2007-07-27 12:48:14 UTC
Created attachment 160114 [details]
Reproducer

Comment 2 Karsten Hopp 2007-08-09 15:24:00 UTC
I think you need to do the following as automake won't know about the subdir
otherwise:
- add  AC_CONFIG_FILES([src/Makefile]) to configure.ac in the main directory
- echo "SUBDIRS = src" > Makefile.am
- echo "bin_PROGRAMS = main" > src/Makefile.am

Comment 3 Miloslav Trmač 2007-08-09 15:35:32 UTC
Automake does already know about the subdirectory, see e.g.

@AMDEP_TRUE@@am__include@ @am__quote@src/$(DEPDIR)/main.Po@am__quote@

in the generated Makefile.in.  If automake didn't interpret src/main specially,
the line would have to be

@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/src/main.Po@am__quote@

wouldn't it?

Using a separate Makefile for the subdirectory completely defeats the point of
using subdir-objects.

Comment 4 Karsten Hopp 2007-08-13 11:35:57 UTC
do you remember which package had this problem ? I'd remove AC_PROG_LIBTOOL from
configure.ac in this testcase as it isn't required anywhere, but this most
probably won't fix the issues in the original package.

Comment 5 Miloslav Trmač 2007-08-13 11:42:39 UTC
rawhide's audit - but that's irrelevant, IMHO.

I'm reporting this because it is a bug and because it should eventually be
fixed, not because I need a workaround.


Note You need to log in before you can comment on or make changes to this bug.