Bug 249878 - After updating some packages, sudo behaves unexpectedly.
After updating some packages, sudo behaves unexpectedly.
Status: CLOSED DUPLICATE of bug 249857
Product: Fedora
Classification: Fedora
Component: sudo (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Peter Vrabec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-27 12:29 EDT by Ashish Shukla
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-31 17:52:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ashish Shukla 2007-07-27 12:29:15 EDT
Description of problem:
After updating and installing following packages as reported by "pup" and
restarting my PC, and booting into new kernel (2.6.22.1-33.fc7), "sudo" is
behaving unexpectedly. The timestamp files or even directories, it creates in
"/var/run/sudo" have their time, set to a time in future (current time + UTC
timezone offset for my timezone). My RTC works in local timezone, i.e. "IST".
I've even tried deleting "/var/run/sudo", but problem is still there.

List of packages upgraded
--------------------------
Jul 27 21:09:50 Updated: bind-libs.x86_64 9.4.1-8.P1.fc7
Jul 27 21:10:50 Updated: graphviz.x86_64 2.12-8.fc7
Jul 27 21:10:51 Updated: bind-utils.x86_64 9.4.1-8.P1.fc7
Jul 27 21:11:02 Updated: kernel-headers.x86_64 2.6.22.1-33.fc7
Jul 27 21:11:03 Updated: k3b-extras-nonfree.x86_64 1.0.3-1.lvn7
Jul 27 21:11:13 Updated: meld.noarch 1.1.5-2.fc7
Jul 27 21:11:27 Updated: kernel-doc.noarch 2.6.22.1-33.fc7
Jul 27 21:12:16 Installed: kernel-devel.x86_64 2.6.22.1-33.fc7
Jul 27 21:13:03 Installed: kernel.x86_64 2.6.22.1-33.fc7

Version-Release number of selected component (if applicable):
sudo-1.6.8p12-14.fc7
pam-0.99.7.1-5.1.fc7


How reproducible:
Reproducible everytime

Steps to Reproduce:
1. On shell, with non-privileged user, execute "sudo ls"
2. Enter the password, "sudo" process asks
3. Now, re-execute "sudo ls", it again asks for the password, saying "sudo:
timestamp too far in the future:"
  
Actual results:
It asks for the password again, even if it is executed immediately afters its
successful execution first time.

Expected results:
It shouldn't ask for password, if its next invocation is within 5 minutes of the
first invocation.

Additional info:
File: /etc/sudoers
===================
[root@chatteau /]# grep -v ^# /etc/sudoers |grep -v ^[[:space:]]*$
Cmnd_Alias NETWORKING = /sbin/route, /sbin/ifconfig, /bin/ping, /sbin/dhclient,
/usr/bin/net, /sbin/iptables, /usr/bin/rfcomm, /usr/bin/wvdial, /sbin/iwconfig,
/sbin/mii-tool
Cmnd_Alias SOFTWARE = /bin/rpm, /usr/bin/up2date, /usr/bin/yum
Cmnd_Alias SERVICES = /sbin/service, /sbin/chkconfig
Cmnd_Alias LOCATE = /usr/sbin/updatedb
Cmnd_Alias STORAGE = /sbin/fdisk, /sbin/sfdisk, /sbin/parted, /sbin/partprobe,
/bin/mount, /bin/umount
Cmnd_Alias DELEGATING = /usr/sbin/visudo, /bin/chown, /bin/chmod, /bin/chgrp 
Cmnd_Alias PROCESSES = /bin/nice, /bin/kill, /usr/bin/kill, /usr/bin/killall
Cmnd_Alias DRIVERS = /sbin/modprobe
Defaults    requiretty
Defaults    env_reset
Defaults    env_keep = "COLORS DISPLAY HOSTNAME HISTSIZE INPUTRC KDEDIR \
                        LS_COLORS MAIL PS1 PS2 QTDIR USERNAME \
                        LANG LC_ADDRESS LC_CTYPE LC_COLLATE LC_IDENTIFICATION \
                        LC_MEASUREMENT LC_MESSAGES LC_MONETARY LC_NAME LC_NUMERIC \
                        LC_PAPER LC_TELEPHONE LC_TIME LC_ALL LANGUAGE LINGUAS \
                        _XKB_CHARSET XAUTHORITY"
root    ALL=(ALL)       ALL
%wheel  ALL=(ALL)       ALL

Output of "groups":
====================
[wahjava@chatteau ~]$ groups
wahjava wheel uucp pulse-rt

Output of "date; hwclock":
===========================
[root@chatteau /]# date; hwclock
Fri Jul 27 21:53:08 IST 2007
Fri 27 Jul 2007 09:53:10 PM IST  -0.751668 seconds

Output of "sudo ls; sudo ls":
==============================
[wahjava@chatteau emacs500]$ sudo ls ; sudo ls

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

Password:
server
sudo: timestamp too far in the future: Jul 28 02:48:33 2007

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

Password:
server
Comment 1 Chuck Ebbert 2007-07-31 17:52:16 EDT

*** This bug has been marked as a duplicate of 249857 ***

Note You need to log in before you can comment on or make changes to this bug.