Bug 249885 - GraphicsMagick segmentation fault on identify command
Summary: GraphicsMagick segmentation fault on identify command
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: GraphicsMagick   
(Show other bugs)
Version: 7
Hardware: i686 Linux
low
high
Target Milestone: ---
Assignee: Andreas Thienemann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-27 16:49 UTC by Dirk Schlüter
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version: 1.1.8-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-30 17:05:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace gm identify img_26720.jpg (22.88 KB, text/plain)
2007-07-27 16:49 UTC, Dirk Schlüter
no flags Details

Description Dirk Schlüter 2007-07-27 16:49:51 UTC
Description of problem:

GraphicsMagick returns a segmentation fault on image reading. I've tried many
different JPS's

Version-Release number of selected component (if applicable):

GraphicsMagick-1.1.7-7.fc7

How reproducible:

ImageMagick:

# identify img_26720.jpg 
img_26720.jpg JPEG 800x533 800x533+0+0
DirectClass 8-bit 66.8496kb

GraphicsMagick :

# gm identify img_26720.jpg 
Speicherzugriffsfehler (segmentation fault)
  
Actual results:

Segmentation fault.

Expected results:

Return image information.

Additional info:

I want use GraphicsMagick with TYPO3 on a fedora 7 installation. Reading
images failed, because of GraphicsMagick's SegFaults. ImageMagick-6.3.2.9-3.fc7
doesn't work correctly with TYPO3, so TYPO3's Image Processing is not really
usable in Fedora 7.

strace info as attachment.

Comment 1 Dirk Schlüter 2007-07-27 16:49:51 UTC
Created attachment 160127 [details]
strace gm identify img_26720.jpg

Comment 2 Rex Dieter 2007-07-27 18:33:30 UTC
confirmed

Comment 3 Andreas Thienemann 2007-07-28 15:08:26 UTC
There is a 1.1.8 maintenance release planned for this weekend by the GM maintainer.

It is assumed that this problem will be fixed in the upcoming gm package.

Comment 4 Fedora Update System 2007-07-30 17:04:59 UTC
GraphicsMagick-1.1.8-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.