This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 24989 - RAID boot with 2.4 kernel
RAID boot with 2.4 kernel
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-25 18:46 EST by Thomas Dodd
Modified: 2015-01-04 17:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-25 22:33:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas Dodd 2001-01-25 18:46:12 EST
The 2.4.0-0.43.12 kernel will not boot with / on a RAID volume.
2.4.0-0.99.5 looks to have the same problems.

The kernel config options were moved so CONFIG_MD_BOOT
is not selectable when RAID is a module (raid0.o, raid1.o).

RAID autodetect doesn't work when IDE is modular, since th
md driver runs autodetect prior to the IDE modules loading
and detecting the devices.

I changed linux/drivers/md/Config.in to move the autodetect
option to no require built-in raid, but the IDE issue hits.

Building IDE, MD, and RAIDx into rthe kernel works.

I'm testing 2.4.0-0.99.5 now, but the configfile still has
the autodetect option depending on builtin RAID drivers.
Comment 1 Dave Jones 2004-10-25 22:33:49 EDT
going through old unclosed bugs..
Did this ever get resolved? Does this problem still exist
in our current Fedora/RHEL products ?

Please reopen if this is still a problem.

Thanks.
Comment 2 Thomas Dodd 2004-10-26 09:43:51 EDT
I'd forgotten this. It was working throughmost of the 2.4 based
releases. RHL9 worked fine. I nolonger have SW RAID so I cannot say more.

Note You need to log in before you can comment on or make changes to this bug.