Bug 249901 - perl-XML-DOM obsoltes conflicts with packages requiring perl-libxml-enno
perl-XML-DOM obsoltes conflicts with packages requiring perl-libxml-enno
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: perl-XML-DOM (Show other bugs)
el4
All Linux
low Severity medium
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-27 15:19 EDT by Dave Botsch
Modified: 2007-09-13 11:43 EDT (History)
5 users (show)

See Also:
Fixed In Version: 20070913
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-13 11:43:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Botsch 2007-07-27 15:19:06 EDT
Description of problem:

the perl-XML-DOM package spec file specifies that this package obsolotes
perl-libxml-enno ... however, the package perl-libxml-enno is required by
foomatic. So, yum updates fail when this conflict arises.

Version-Release number of selected component (if applicable):


How reproducible:

so far, 100% of time on many machines


Steps to Reproduce:
1. Set up yum to point to the rhel4 epel repository
2. Install foomatic and perl-libxml-enno
3. Attempt a 'yum update' with or without the --obsoletes flag
  
Actual results:

failed dependencies in that perl-libxml-enno is required by foomatic.

Expected results:

yum updates packages appropriately/

Additional info:
Comment 1 James Ralston 2007-07-30 15:18:03 EDT
Looks like someone forgot to run rpmlint.  :(

$ rpmlint -i RPMS/noarch/perl-XML-DOM-1.44-2.noarch.rpm 
E: perl-XML-DOM obsolete-not-provided perl-libxml-enno
The obsoleted package must also be provided to allow clean upgrade paths
and not to break dependencies.

Here's how to fix:

$ diff -U 3 perl-XML-DOM.spec.orig perl-XML-DOM.spec
--- perl-XML-DOM.spec.orig      2006-06-29 16:09:43.000000000 -0400
+++ perl-XML-DOM.spec   2007-07-30 15:16:36.000000000 -0400
@@ -14,6 +14,7 @@
 BuildRequires:  perl(XML::RegExp)
 Requires:       perl(XML::Parser)
 Requires:  perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
+Provides:       perl-libxml-enno <= 1.02
 Obsoletes:      perl-libxml-enno <= 1.02
 
 %description

Please patch, bump the rev, and rebuild.
Comment 2 Kevin Fenzi 2007-07-30 19:28:15 EDT
Ah, but perl-libxml-enno is in RHEL4/CentOS4 base repos.

So, why is this package replacing/obsoleting a package thats in the base repos?
The current EPEL guidelines have: "Thus packages from EPEL should never replace
packages from the target base distribution".

Comment 3 Orion Poplawski 2007-07-30 22:52:20 EDT
Yes, perl-XML-DOM was mistakenly built for EL-4.  I'm attempting to get it
removed from the repository.
Comment 4 James Ralston 2007-07-31 13:01:28 EDT
Whoops; I forgot to check for that before I posted comment #1.

As an aside, I can understand why the "packages from EPEL should never replace
packages from the target base distribution" rule is necessary, but it is going
to vastly reduce the usefulness of EPEL.  :(
Comment 5 Dave Botsch 2007-09-05 17:28:22 EDT
Hi, guys. Still broken as of this time (having to use the painful workaround of
telling everyone to add this package to their excludes list).
Comment 6 Kevin Fenzi 2007-09-05 19:45:10 EDT
Sorry for the delay here. ;( 
I will try and dig through the scripts tonight and get it removed from the
repository and pushed out. 
Comment 7 Kevin Fenzi 2007-09-06 01:17:41 EDT
I think I know how to clean this up now, but I am not 100% sure, so I am going
to get confirmation before I possibly mess up the repository. 

Hopefully it will be gone in the next day or so... sorry again for the delay.
Comment 8 Kevin Fenzi 2007-09-12 19:20:13 EDT
Ugh. Sorry this took so very long to get done. 

I think it should now finally be removed from the repos. 

It might take a bit to mirror out, but could you confirm that it's not showing
up and close this bug?
Comment 9 Orion Poplawski 2007-09-13 11:43:27 EDT
Confirmed that it is gone in my local mirror after the latest sync.  I don't
think this is an issue, but the following are still present in the repository:

epel/4/i386/headers/perl-XML-DOM-0-1.44-2.el4.noarch.hdr
epel/4/ppc/headers/perl-XML-DOM-0-1.44-2.el4.noarch.hdr
epel/4/x86_64/headers/perl-XML-DOM-0-1.44-2.el4.noarch.hdr

Note You need to log in before you can comment on or make changes to this bug.