Bug 249901 - perl-XML-DOM obsoltes conflicts with packages requiring perl-libxml-enno
Summary: perl-XML-DOM obsoltes conflicts with packages requiring perl-libxml-enno
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: perl-XML-DOM
Version: el4
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2007-07-27 19:19 UTC by Dave Botsch
Modified: 2007-09-13 15:43 UTC (History)
5 users (show)

Fixed In Version: 20070913
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2007-09-13 15:43:27 UTC
Type: ---

Attachments (Terms of Use)

Description Dave Botsch 2007-07-27 19:19:06 UTC
Description of problem:

the perl-XML-DOM package spec file specifies that this package obsolotes
perl-libxml-enno ... however, the package perl-libxml-enno is required by
foomatic. So, yum updates fail when this conflict arises.

Version-Release number of selected component (if applicable):

How reproducible:

so far, 100% of time on many machines

Steps to Reproduce:
1. Set up yum to point to the rhel4 epel repository
2. Install foomatic and perl-libxml-enno
3. Attempt a 'yum update' with or without the --obsoletes flag
Actual results:

failed dependencies in that perl-libxml-enno is required by foomatic.

Expected results:

yum updates packages appropriately/

Additional info:

Comment 1 James Ralston 2007-07-30 19:18:03 UTC
Looks like someone forgot to run rpmlint.  :(

$ rpmlint -i RPMS/noarch/perl-XML-DOM-1.44-2.noarch.rpm 
E: perl-XML-DOM obsolete-not-provided perl-libxml-enno
The obsoleted package must also be provided to allow clean upgrade paths
and not to break dependencies.

Here's how to fix:

$ diff -U 3 perl-XML-DOM.spec.orig perl-XML-DOM.spec
--- perl-XML-DOM.spec.orig      2006-06-29 16:09:43.000000000 -0400
+++ perl-XML-DOM.spec   2007-07-30 15:16:36.000000000 -0400
@@ -14,6 +14,7 @@
 BuildRequires:  perl(XML::RegExp)
 Requires:       perl(XML::Parser)
 Requires:  perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
+Provides:       perl-libxml-enno <= 1.02
 Obsoletes:      perl-libxml-enno <= 1.02

Please patch, bump the rev, and rebuild.

Comment 2 Kevin Fenzi 2007-07-30 23:28:15 UTC
Ah, but perl-libxml-enno is in RHEL4/CentOS4 base repos.

So, why is this package replacing/obsoleting a package thats in the base repos?
The current EPEL guidelines have: "Thus packages from EPEL should never replace
packages from the target base distribution".

Comment 3 Orion Poplawski 2007-07-31 02:52:20 UTC
Yes, perl-XML-DOM was mistakenly built for EL-4.  I'm attempting to get it
removed from the repository.

Comment 4 James Ralston 2007-07-31 17:01:28 UTC
Whoops; I forgot to check for that before I posted comment #1.

As an aside, I can understand why the "packages from EPEL should never replace
packages from the target base distribution" rule is necessary, but it is going
to vastly reduce the usefulness of EPEL.  :(

Comment 5 Dave Botsch 2007-09-05 21:28:22 UTC
Hi, guys. Still broken as of this time (having to use the painful workaround of
telling everyone to add this package to their excludes list).

Comment 6 Kevin Fenzi 2007-09-05 23:45:10 UTC
Sorry for the delay here. ;( 
I will try and dig through the scripts tonight and get it removed from the
repository and pushed out. 

Comment 7 Kevin Fenzi 2007-09-06 05:17:41 UTC
I think I know how to clean this up now, but I am not 100% sure, so I am going
to get confirmation before I possibly mess up the repository. 

Hopefully it will be gone in the next day or so... sorry again for the delay.

Comment 8 Kevin Fenzi 2007-09-12 23:20:13 UTC
Ugh. Sorry this took so very long to get done. 

I think it should now finally be removed from the repos. 

It might take a bit to mirror out, but could you confirm that it's not showing
up and close this bug?

Comment 9 Orion Poplawski 2007-09-13 15:43:27 UTC
Confirmed that it is gone in my local mirror after the latest sync.  I don't
think this is an issue, but the following are still present in the repository:


Note You need to log in before you can comment on or make changes to this bug.