Bug 249911 - hangcheck-timer vs. hibernate (swsusp)
hangcheck-timer vs. hibernate (swsusp)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-27 16:36 EDT by Jan Kratochvil
Modified: 2009-01-08 23:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-08 23:49:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Hibernate + resume logs; please see the 2x5 minutes time distance there. (14.76 KB, text/plain)
2007-09-24 13:37 EDT, Jan Kratochvil
no flags Details

  None (edit)
Description Jan Kratochvil 2007-07-27 16:36:58 EDT
Description of problem:
Tried to hibernate but on resume the machine got frozen.

Version-Release number of selected component (if applicable):
kernel-2.6.22.1-33.fc7.x86_64

How reproducible:
Not tried.

Steps to Reproduce:
1. modprobe hangcheck-timer hangcheck_reboot=1
2. Click gnome-power-manager -> Hibernate
3. Close+open the notebook lid.

Actual results:
Messages not caught but:
... the whole hibernate-resume process ...
Hangcheck timer is rebooting the machine
[ hang - the reboot even did not occur ]

Expected results:
... the whole hibernate-resume process ...
[ Successful resume. ]

Additional info:
Comment 1 Christopher Brown 2007-09-21 07:43:19 EDT
Hello Jan,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris
Comment 2 Jan Kratochvil 2007-09-21 08:08:34 EDT
Chris,
running now on F8/Rawhide, going to recheck if this Bug is still valid there.
Sure I no longer load `hangcheck-timer' after I submitted this Bug.
(After some updates get downloaded to make it worth the reboot/crash.)
Comment 3 Jan Kratochvil 2007-09-21 13:22:18 EDT
Currently Hibernate does not work at all on Lenovo T60:
kernel-2.6.23-0.189.rc6.git8.fc8.x86_64
It hangs on:
  Suspending console(s) ...
during the restore.
Hibernate was already working for kernel 171 (not 100% about the number).
There should be dependency on the specific Lenovo T60 hibernate Bug but there
are multiple similiar open ones etc.
Comment 4 Christopher Brown 2007-09-21 19:30:40 EDT
Hi Jan,

Okay, thanks for the update. Please could you try the following quirks and see
if they help:

pm-hibernate --quirk-s3-bios
pm-hibernate --quirk-s3-mode

Cheers
Chris
Comment 5 Jan Kratochvil 2007-09-24 13:37:31 EDT
Created attachment 204331 [details]
Hibernate + resume logs; please see the 2x5 minutes time distance there.

Hi Chris,

all the tests were done on: kernel-2.6.23-0.195.rc7.git3.fc8.x86_64
(and even otherwise updated Rawhide)
http://smolt.fedoraproject.org/show?UUID=10f0cc48-4a2f-46d0-a176-c8efd064f972

While I tried these two commands it had no effect on the behavior:
	pm-hibernate --quirk-s3-bios
	pm-hibernate --quirk-s3-mode

The suspend always works fine.

The hibernation always works if one waits long enough.

In most cases before it starts suspending (blank screen) and after the restore
before the X screen is shown (Suspending console(s) last message shown) it
hangs for exactly 5 minutes (so suspend like 5:34 and resume 5:06 etc.).  
I expect some timeout there.

If I rmmod iwl3945 and kvm+kvm_intel, still the 5 minute delay occurs.

If I disconnect these USB devices ("docking") the 5 minute delay usually does
not occur (but I saw it once during the restore):
Bus 001 Device 008: ID 041e:3010 Creative Technology, Ltd SoundBlaster MP3+
Bus 001 Device 005: ID 04f2:0116 Chicony Electronics Co., Ltd KU-2971 German
Keyboard
Bus 001 Device 004: ID 046d:c040 Logitech, Inc.
	[mouse]
Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc.
	[USB hub]
No lsmod change has been seen after this disconnection.

If I shortly press the power button (normally it does `init 0' despite I have
set `Ask me' in Gnome Power Manager) during the 5 minute delay during suspend,
it will immediately abort the delay and successfully starts suspending (and
turns off).  If I press the power button during the resume 5 minute delay,
nothing happens.

It is offtopic of this Bug but it is a bit prerequisite.
Are you aware which Bug is this a DUPLICATE of?
Comment 6 Bug Zapper 2008-04-04 09:28:02 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 7 Bug Zapper 2008-11-26 02:36:45 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bug Zapper 2009-01-08 23:49:17 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.