Bug 249918 - nfs server no longer mountable
nfs server no longer mountable
Status: CLOSED DUPLICATE of bug 249857
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-27 17:13 EDT by Jan Kratochvil
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: kernel-2.6.22.1-41.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-20 14:01:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.pcap of the unsuccessful mount attempt. (2.43 KB, application/octet-stream)
2007-07-27 17:13 EDT, Jan Kratochvil
no flags Details

  None (edit)
Description Jan Kratochvil 2007-07-27 17:13:23 EDT
Description of problem:
After upgrading kernel I can no longer serve NFS shares.

Version-Release number of selected component (if applicable):
kernel-2.6.22.1-33.fc7.x86_64 (the server side)
(client side tested either this one or kernel-2.6.21-1.3228.fc7.x86_64)
nfs-utils-1.0.12-4.fc7.x86_64
nfs-utils-lib-1.0.8-8.fc7.x86_64

How reproducible:
Not tried again.

Steps to Reproduce:
1. /etc/exports: /home   172.20.0.2(rw,no_root_squash,async)
2. service nfs restart
3. export -rav
4. client: mount -tnfs -o rw,hard,nointr,rsize=4096,wsize=4096,suid,dev,async
172.20.0.1:/home /home

Actual results:
server: Jul 27 22:57:05 host0 mountd[22959]: authenticated mount request from
virt:985 for /home (/home)
client: mount: 172.20.0.1:/home failed, reason given by server: Permission denied

Expected results:
Successfully mounted share.

Additional info:
Attached a pcap dump just showing ERR_ACCESS on the packet level.
Simple reboot of the server side back to kernel-2.6.21-1.3228.fc7.x86_64 fixed
the problem.
Comment 1 Jan Kratochvil 2007-07-27 17:13:23 EDT
Created attachment 160143 [details]
.pcap of the unsuccessful mount attempt.
Comment 2 Göran Uddeborg 2007-08-14 16:38:47 EDT
Could this is a duplicate of bug 249857.  I see this too when I try to mount
file systems from a freshly booted machine running kernel
kernel-2.6.22.1-33.fc7.  But after two hours, it is possible to mount from it. 
I'm in UTC +0200.

I'll shortly upgrade to kernel-2.6.22.1-41.fc7 and see if it solves the problem,
but I thought I'd mention this here right away.
Comment 3 Göran Uddeborg 2007-08-20 14:01:37 EDT
After upgrading to -41 this no longer happens.  It does indeed seem to be the
same problem.

*** This bug has been marked as a duplicate of 249857 ***

Note You need to log in before you can comment on or make changes to this bug.