Bug 249928 - genisoimage-1.1.6 includes /.. in Rock Ridge and thus fails to merge sessions
Summary: genisoimage-1.1.6 includes /.. in Rock Ridge and thus fails to merge sessions
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cdrkit   
(Show other bugs)
Version: 7
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-28 02:59 UTC by Ben Caradoc-Davies
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 1.1.6-5.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-03 21:16:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben Caradoc-Davies 2007-07-28 02:59:53 UTC
Description of problem:
When using genisoimage to create a Rock Ridge + Joliet session with -r -J, the
Rock Ridge directory "/.."  is included. When merging a subsequent session with
-r -J -C MMM,NNN -M /dev/cdrom, it fails because "/.." and (e.g.) "tmpdir/.."
have the same Rock Ridge name.

mkisofs for fc6 did not have this problem, but in that case the -M 2,0,0 faux
scsi notation was used. It is possible the use of -M /dev/cdrom (required for
Fedora 7 libata) provokes this new behaviour (inclusion of "..").

I think this problem is distinct from
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=248262
(bad Joliet).

Version-Release number of selected component (if applicable):
genisoimage-1.1.6

Steps to Reproduce:
1. Create Rock Ridge session
2. Write to multisession CD
3. Create second session for CD
  
Actual results:
Error with duplicate Rock Ridge names.

Expected results:
genisoimage fails with duplicate Rock Ridge names.

Additional info:
Workaround is to roll back to genisoimage-1.1.2-4.fc7.x86_64 (from Fedora
release). This version reports that (e.g.) "tmpdir/.." is ignored when creating
the image.

Given this bug and
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=248262 ,
is it time for a genisoimage-1.1.6 product recall?

yum.conf exclude=genisoimage is your friend.

Comment 1 Harald Hoyer 2007-09-20 15:39:39 UTC
I think, this is the same bug as 248262.

Comment 2 Harald Hoyer 2007-09-20 19:37:53 UTC
Please try
http://koji.fedoraproject.org/koji/buildinfo?buildID=19091

Comment 3 Harald Hoyer 2007-09-21 08:26:51 UTC
Here we go again:
http://koji.fedoraproject.org/koji/buildinfo?buildID=19195

Comment 4 Fedora Update System 2007-09-25 08:24:26 UTC
cdrkit-1.1.6-5.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2007-10-03 21:16:00 UTC
cdrkit-1.1.6-5.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Ben Caradoc-Davies 2007-11-02 23:34:08 UTC
I have tested the new genisoimage and can confirm that this bug is resolved.


Note You need to log in before you can comment on or make changes to this bug.