Bug 249938 - pv guest install failed
pv guest install failed
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-28 04:34 EDT by Thorsten Scherf
Modified: 2009-12-14 16:24 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-31 17:04:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
domain-builder-ng.log (7.99 KB, text/plain)
2007-07-31 16:43 EDT, Thorsten Scherf
no flags Details
virt-manager.log (14.25 KB, text/plain)
2007-07-31 16:44 EDT, Thorsten Scherf
no flags Details
xend.log (317.95 KB, text/plain)
2007-07-31 16:45 EDT, Thorsten Scherf
no flags Details
xend-debug.log (41.29 KB, text/plain)
2007-07-31 16:48 EDT, Thorsten Scherf
no flags Details

  None (edit)
Description Thorsten Scherf 2007-07-28 04:34:15 EDT
Description of problem:
not able to install a pv guest


Version-Release number of selected component (if applicable):
xen-3.0.3-25.0.3.el5

How reproducible:
run virt-manager and install a new machine

Steps to Reproduce:
1.virt-manager
2.new install
3.
  
Actual results:
Error: virtDomainCreateLinux() failed

Expected results:
install starts


Additional info:
install device is a 50G LV 

/var/log/xen/xend.log:
XendError: Error creating domain: (11, 'Resource temporarily unavailable')
[2007-07-28 10:27:56 xend.XendDomainInfo 2604] DEBUG (XendDomainInfo:190)
XendDomainInfo.create(['vm', ['name', 'rhel4'], ['memory', '500'], ['maxmem',
'500'], ['vcpus', '1'], ['uuid', '14e11bc1-bb4f-7b61-100b-37f8a1c37b18'],
['on_poweroff', 'destroy'], ['on_reboot', 'destroy'], ['on_crash', 'destroy'],
['image', ['linux', ['kernel', '/var/lib/xen/vmlinuz.uEEhVE'], ['ramdisk',
'/var/lib/xen/initrd.img.dGhxUt'], ['args', '
method=ftp://192.168.0.99/pub/rhel4/  ']]], ['device', ['vbd', ['dev', 'xvda'],
['uname', 'phy:/dev/vg0/fedora'], ['mode', 'w']]], ['device', ['vif', ['mac',
'00:16:3e:5d:bc:47'], ['bridge', 'xenbr0'], ['script',
'/etc/xen/scripts/vif-bridge']]], ['device', ['vkbd']], ['device', ['vfb',
['type', 'vnc'], ['vncunused', '1']]]])
[2007-07-28 10:27:56 xend.XendDomainInfo 2604] DEBUG (XendDomainInfo:296)
parseConfig: config is ['vm', ['name', 'rhel4'], ['memory', '500'], ['maxmem',
'500'], ['vcpus', '1'], ['uuid', '14e11bc1-bb4f-7b61-100b-37f8a1c37b18'],
['on_poweroff', 'destroy'], ['on_reboot', 'destroy'], ['on_crash', 'destroy'],
['image', ['linux', ['kernel', '/var/lib/xen/vmlinuz.uEEhVE'], ['ramdisk',
'/var/lib/xen/initrd.img.dGhxUt'], ['args', '
method=ftp://192.168.0.99/pub/rhel4/  ']]], ['device', ['vbd', ['dev', 'xvda'],
['uname', 'phy:/dev/vg0/fedora'], ['mode', 'w']]], ['device', ['vif', ['mac',
'00:16:3e:5d:bc:47'], ['bridge', 'xenbr0'], ['script',
'/etc/xen/scripts/vif-bridge']]], ['device', ['vkbd']], ['device', ['vfb',
['type', 'vnc'], ['vncunused', '1']]]]
[2007-07-28 10:27:56 xend.XendDomainInfo 2604] DEBUG (XendDomainInfo:397)
parseConfig: result is {'shadow_memory': None, 'start_time': None, 'uuid':
'14e11bc1-bb4f-7b61-100b-37f8a1c37b18', 'on_crash': 'destroy', 'on_reboot':
'destroy', 'localtime': None, 'image': ['linux', ['kernel',
'/var/lib/xen/vmlinuz.uEEhVE'], ['ramdisk', '/var/lib/xen/initrd.img.dGhxUt'],
['args', ' method=ftp://192.168.0.99/pub/rhel4/  ']], 'on_poweroff': 'destroy',
'bootloader_args': None, 'cpus': None, 'name': 'rhel4', 'backend': [], 'vcpus':
1, 'cpu_weight': None, 'features': None, 'vcpu_avail': None, 'memory': 500,
'device': [('vbd', ['vbd', ['dev', 'xvda'], ['uname', 'phy:/dev/vg0/fedora'],
['mode', 'w']]), ('vif', ['vif', ['mac', '00:16:3e:5d:bc:47'], ['bridge',
'xenbr0'], ['script', '/etc/xen/scripts/vif-bridge']]), ('vkbd', ['vkbd']),
('vfb', ['vfb', ['type', 'vnc'], ['vncunused', '1']])], 'bootloader': None,
'cpu': None, 'maxmem': 500}
[2007-07-28 10:27:56 xend.XendDomainInfo 2604] DEBUG (XendDomainInfo:1264)
XendDomainInfo.construct: None
[2007-07-28 10:27:56 xend.XendDomainInfo 2604] DEBUG (XendDomainInfo:1296)
XendDomainInfo.initDomain: 4 1.0
[2007-07-28 10:27:56 xend 2604] DEBUG (balloon:127) Balloon: 512448 KiB free;
need 512000; done.
[2007-07-28 10:27:56 xend 2604] INFO (image:136) buildDomain os=linux dom=4 vcpus=1
[2007-07-28 10:27:56 xend 2604] DEBUG (image:199) dom            = 4
[2007-07-28 10:27:56 xend 2604] DEBUG (image:200) image          =
/var/lib/xen/vmlinuz.uEEhVE
[2007-07-28 10:27:56 xend 2604] DEBUG (image:201) store_evtchn   = 1
[2007-07-28 10:27:56 xend 2604] DEBUG (image:202) console_evtchn = 2
[2007-07-28 10:27:56 xend 2604] DEBUG (image:203) cmdline        =  
method=ftp://192.168.0.99/pub/rhel4/  
[2007-07-28 10:27:56 xend 2604] DEBUG (image:204) ramdisk        =
/var/lib/xen/initrd.img.dGhxUt
[2007-07-28 10:27:56 xend 2604] DEBUG (image:205) vcpus          = 1
[2007-07-28 10:27:56 xend 2604] DEBUG (image:206) features       = 
[2007-07-28 10:27:56 xend.XendDomainInfo 2604] ERROR (XendDomainInfo:202) Domain
construction failed
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/xen/xend/XendDomainInfo.py", line 195,
in create
    vm.initDomain()
  File "/usr/lib/python2.4/site-packages/xen/xend/XendDomainInfo.py", line 1377,
in initDomain
    raise VmError(str(exn))
VmError: (11, 'Resource temporarily unavailable')
[2007-07-28 10:27:56 xend.XendDomainInfo 2604] DEBUG (XendDomainInfo:1463)
XendDomainInfo.destroy: domid=4
[2007-07-28 10:27:56 xend.XendDomainInfo 2604] DEBUG (XendDomainInfo:1471)
XendDomainInfo.destroyDomain(4)
[2007-07-28 10:27:56 xend 2604] ERROR (SrvBase:88) Request create failed.
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/xen/web/SrvBase.py", line 85, in perform
    return op_method(op, req)
  File "/usr/lib/python2.4/site-packages/xen/xend/server/SrvDomainDir.py", line
82, in op_create
    raise XendError("Error creating domain: " + str(ex))
XendError: Error creating domain: (11, 'Resource temporarily unavailable')
Comment 1 Richard W.M. Jones 2007-07-31 12:08:05 EDT
Is this RHEL5 GA?  If so do you get the same problem with RHEL 5.1 beta
(ie. >= xen-3.0.3-33.el5)?
Comment 2 Thorsten Scherf 2007-07-31 14:57:09 EDT
when using the 5.1 beta from rhn I got this:

Unable to complete install 'libvirt.libvirtError virDomainCreateLinux() failed
POST-Operation schlug fehl: (xend.err "Error creating domain: (22, 'Invalid
argument')")
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 681, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 649, in
start_install
    return self._do_install(consolecb, meter)
  File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 666, in
_do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib/python2.4/site-packages/libvirt.py", line 503, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: virDomainCreateLinux() failed POST-Operation schlug fehl:
(xend.err "Error creating domain: (22, 'Invalid argument')")
'

this only happens when installing a rhel4 pv guest. using rhel5 install rpms to
setup a rhel5 pv guest it works without any problems.
Comment 3 Daniel Berrange 2007-07-31 16:22:26 EDT
Please provide the /root/.virt-manager/virt-manager.log and
/var/log/xen/xend.log and /var/log/domain-builder-ng.log  file from your 5.1
beta attempt.

That error message typically means you tried to boot an unsupported kernel type.
eg 32 bit on 64-bit host, or vica-verca, or a baremetal kernel on a xen PV host.
Comment 4 Thorsten Scherf 2007-07-31 16:43:58 EDT
Created attachment 160357 [details]
domain-builder-ng.log
Comment 5 Thorsten Scherf 2007-07-31 16:44:31 EDT
Created attachment 160358 [details]
virt-manager.log
Comment 6 Thorsten Scherf 2007-07-31 16:45:12 EDT
Created attachment 160359 [details]
xend.log
Comment 7 Thorsten Scherf 2007-07-31 16:48:34 EDT
Created attachment 160360 [details]
xend-debug.log
Comment 8 Thorsten Scherf 2007-07-31 17:04:32 EDT
looks like the vmlinuz transfered from the install host was corrupt. after
replacing that file it worked.

Note You need to log in before you can comment on or make changes to this bug.