This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 249944 - incorrect setting of GTK_IM_MODULE
incorrect setting of GTK_IM_MODULE
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-28 07:07 EDT by Matthias Kredler
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-08 21:28:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
~/.scim/config file (2.79 KB, text/plain)
2007-07-30 23:11 EDT, Matthias Kredler
no flags Details
~/.xinputrc (690 bytes, text/plain)
2007-08-01 10:15 EDT, Matthias Kredler
no flags Details

  None (edit)
Description Matthias Kredler 2007-07-28 07:07:17 EDT
Description of problem:

I am running Fedora 7 using English as the system
language. I installed Japanese language support
later after the main installation and carried out
all recommended updates for f7. Now, I can
perfectly see all Japanese 
websites etc., so it seems that I have all the 
necessary fonts etc. However, I cannot switch
to scim input mode using the the im-chooser
in gedit, firefox etc.


Version-Release number of selected component (if applicable):

scim 1.4.5


How reproducible:

always


Steps to Reproduce:

1. Install f7 without Japanese language support
2. Install Japanese language support later
3. Use im-chooser to switch to 'Custom input method: scim'

  
Actual results:

On next login or boot, see the im-chooser on the gnome
desktop with 'Custom input method: scim' selected. However,
in text applications such as gedit or Firefox,
scim cannot be activated by the hotkeys Ctrl-Space,
Alt+`


Expected results:

On next login or boot, should be able to start Japanese 
input method using Ctrl+Space or Alt+`. 


Additional info:

When I try to run scim from the command line, the following
output is given:

$ scim
Smart Common Input Method 1.4.5

Launching a SCIM process with x11...
Loading socket Config module ...
Creating backend ...
Loading x11 FrontEnd module ...
Failed to load x11 FrontEnd module.
SCIM has exited abnormally.
Comment 1 Jens Petersen 2007-07-29 19:48:06 EDT
Did you manage to update to the latest scim package from F7 updates?
This sounds like a duplicate of bug 241629 and you need to remove ~/.scim/config
or you may prefer just to set a trigger (hot) key (eg Ctrl+space) from
scim-setup.
Comment 2 Matthias Kredler 2007-07-30 04:22:18 EDT
Thanks for the quick response!

It seems that I got all the updates fro scim:
$ su -c "yum update scim"
Password: 
Loading "installonlyn" plugin
Setting up Update Process
Could not find update match for scim
No Packages marked for Update/Obsoletion

I tried both your tips:
1. set hot keys with scim-setup
2. remove the file ~/.scim/config

The system still behaves the same way as
described before, even after re-booting.

Maybe something with x11 is wrong? I still get

$ scim
Smart Common Input Method 1.4.5

Launching a SCIM process with x11...
Loading socket Config module ...
Creating backend ...
Loading x11 FrontEnd module ...
Failed to load x11 FrontEnd module.
SCIM has exited abnormally.


Comment 3 Jens Petersen 2007-07-30 21:26:58 EDT
After starting a desktop session what does "ps x | grep scim"
and "printenv | grep -i scim" output for you?
Comment 4 Jens Petersen 2007-07-30 21:29:43 EDT
The output of "rpm -qa scim\*|sort" would also be useful.
Comment 5 Matthias Kredler 2007-07-30 22:46:15 EDT
$ ps x | grep scim
 2664 ?        Ss     0:00 /usr/lib/scim-1.0/scim-launcher -d -c simple -e 
all -f socket --no-stay
 2670 ?        Ss     0:00 /usr/lib/scim-1.0/scim-helper-manager
 2671 ?        Ssl    0:00 /usr/lib/scim-1.0/scim-panel-gtk --display :0.0 -c 
socket -d --no-stay
 2673 ?        Ss     0:00 /usr/lib/scim-1.0/scim-launcher -d -c socket -e 
socket -f x11
 2839 pts/0    S+     0:00 grep scim


$ printenv | grep -i scim
QT_IM_MODULE=scim
XMODIFIERS=@im=SCIM
GTK_IM_MODULE=scim


$ rpm -qa scim\*|sort

scim-1.4.5-21.fc7
scim-anthy-1.2.4-1.fc7
scim-bridge-0.4.10-1.fc7
scim-bridge-gtk-0.4.10-1.fc7
scim-libs-1.4.5-21.fc7
scim-m17n-0.2.1-1.fc7

Comment 6 Jens Petersen 2007-07-30 23:00:20 EDT
Thanks.  Could you attach your ".scim/config" please, too.
Comment 7 Matthias Kredler 2007-07-30 23:11:23 EDT
Created attachment 160291 [details]
~/.scim/config file
Comment 8 Jens Petersen 2007-07-31 02:57:36 EDT
Looking at your package list I have an idea what the problem might be.
Perhaps you have /usr/lib/gtk-2.0/immodules and /usr/lib64/gtk-2.0/immodules
but only scim-bridge-gtk.x86_64 installed?

I am wondering why you have:
GTK_IM_MODULE=scim (you do not have scim-gtk installed) and
QT_IM_MODULE=scim (since you do not have scim-qtimm installed).

Do you have a ~/.xinputrc file?

The easiest solution should be to install the other scim-bridge-gtk
package assuming you are not deliberately avoiding multilib packages?

Normally you can do that with "yum install scim-bridge-gtk" which
should pull in the other arch package.
Comment 9 Matthias Kredler 2007-07-31 05:12:12 EDT
yum didn't do anything when I tried what you suggested
regarding scim-bridge-gtk:

$ su -c "yum install scim-bridge-gtk" 
Password: 
Loading "installonlyn" plugin
Setting up Install Process
Parsing package install arguments
Nothing to do

Concerning your other questions:
Yes, I do have a ~/.xinputrc file. I do also have /usr/lib/gtk-2.0/immodules,
but I don't have /usr/lib64/gtk-2.0/immodules (there is no lib64 folder at
all). As for the version of scim-bridge-gtk, from "yum search" I get the
following:

scim-bridge-gtk.i386                     0.4.10-1.fc7           installed       
Matched from:
scim-bridge-gtk
Comment 10 Jens Petersen 2007-07-31 23:52:25 EDT
Sorry, I was confusing with another bug report related to x86_64.

Anyway wonder why you have GTK_IM_MODULE=scim.
It should be GTK_IM_MODULE=scim-bridge.

Is your ~/.xinputrc a symlink to scim.conf?
Perhaps you are setting GTK_IM_MODULE=scim?

What is your output of "ls -l /usr/lib/gtk-2.0/immodules"?

(If you run say "GTK_IM_MODULE=scim-bridge gedit" (for a new gedit session),
does scim work for you.)
Comment 11 Matthias Kredler 2007-08-01 10:15:48 EDT
Created attachment 160415 [details]
~/.xinputrc
Comment 12 Matthias Kredler 2007-08-01 10:22:06 EDT
Here are the answers to your questions:

1. I have attached my .xinputrc file... I'm sorry, but it is beyond
   my understanding!

2. $ ls -l /usr/lib/gtk-2.0/immodules
total 80
-rwxr-xr-x 1 root root 72776 2007-02-26 09:33 im-scim-bridge.so

3. When I run "GTK_IM_MODULE=scim-bridge gedit", I actually see the
scim toolbar (this is the first time this happens!), but I still 
can't switch to the Japanese anthy mode. In the scim input method
setup gui, I see an entire point for anthy and it tells me I can 
toggle on/off by Ctrl+j, but this is not really the case. Also,
I don't see any anthy symbol in the toolbar (as was the case for
f6, if I'm not mistaken...)
Comment 13 Jens Petersen 2007-08-01 20:20:23 EDT
(In reply to comment #12)
> 1. I have attached my .xinputrc file... I'm sorry, but it is beyond
>    my understanding!

Ok that is fine - probably it is a symlink.

> 2. $ ls -l /usr/lib/gtk-2.0/immodules
> total 80
> -rwxr-xr-x 1 root root 72776 2007-02-26 09:33 im-scim-bridge.so

Good.  Hmmm so why GTK_IM_MODULE is getting set wrong - very strange.

> 3. When I run "GTK_IM_MODULE=scim-bridge gedit", I actually see the
> scim toolbar (this is the first time this happens!), but I still 
> can't switch to the Japanese anthy mode.

So if you try to select Anthy from the Toolbar menu when running gedit
what happens?  And if you run scim-setup what does it say in
FrontEnd > Global Setup --> Hotkeys > Trigger: ?

> In the scim input method
> setup gui, I see an entire point for anthy and it tells me I can 
> toggle on/off by Ctrl+j, but this is not really the case.

Well that is a binding for within anthy - to switch between ascii and
kana input (_A <-> あ) modes.

> Also, I don't see any anthy symbol in the toolbar (as was the case for
> f6, if I'm not mistaken...)

I guess that is because anthy is not turned on.
Comment 14 Matthias Kredler 2007-08-03 22:49:10 EDT
Concerning your questions:

In scim-setup, under FrontEnd > Global Setup --> Hotkeys > Trigger
I have:
Zenkaku_Hankaku,Alt+grave,Control+space
These do indeed work to switch on and off the toolbar, if I 
start gedit with "GTK_IM_MODULE=scim-bridge gedit"

In the scim toolbar menu, I cannot select anthy -- it doesn't
appear as an option.

You say that is because it is not switched on -- the problem
is I cannot see how to switch it on. In the scim-setup,
'anthy' as a point below 'IM-engine'. HOwever, in the list of
'installed input method services' under 'Global Setup' below
'IM-engine', I only see 'English European' and 'Raw Code' --
I guess here I would have to switch it on, right?

Thanks for your patience, this turns out to be quite long,
and maybe I'm asking some very easy questions here and
I'm waisting your time, but I couldn't find the answers
in the fedora documentation!

Matthias
Comment 15 Jens Petersen 2007-08-06 04:10:57 EDT
I still don't understand why you are getting GTK_IM_MODULE=scim
and not GTK_IM_MODULE=scim-bridge as you should.

Also don't know why anthy does not appear in the menu for you.

Could you try creating a new user account and logging in with that
user to see if it should be make a difference.

I feel like something is broken in your environment but I don't know what.
If you have another machine you can test on or can test with the F7 LiveCD
say it might help but still we may not know how to fix your current install.

Anyway for now you can probably install scim-gtk as a workaround.
It contains the immodule in your GTK_IM_MODULE - it may help,
but scim-bridge should work for you too.
Comment 16 Matthias Kredler 2007-08-06 10:03:14 EDT
I installed a new user, but the problems are exactly the same --
the principal one being that anthy still doesn't show up in
the menu.

Later, I installed the scim-gtk package. From then on, I could
start the scim toolbar in any application by Ctrl-Space (this wasn't
possible before -- I had to use "GTK_IM_MODULE=scim-bridge gedit" 
from the command line). However, anthy still doesn't show up
in the menu. 

For the next month or so, I am still in Japan and don't have
access to my desktop, also getting a live CD may be hard, so
it's currently not so easy to check on other systems...
By the way, by now I would be fine with any workaround that
works more or less! 

Thanks for your continued efforts,
Matthias
Comment 17 Jens Petersen 2007-08-06 19:29:06 EDT
What does "scim -l" output for you?
Do you have the anthy package installed?
Comment 18 Matthias Kredler 2007-08-06 22:50:25 EDT
FINALLY IT WORKS!!! It turns out that I didn't have the 'anthy'
package -- I had 'scim-anthy', I thought that was all I needed,
and I guess that was why anthy appeared as an item in my 'scim-
setup' tool, but Japanese didn't appear as an option in the
languages in the scim toolbar.

So to summarize:
Now (after installing gtk), I can start the scim toolbar from
any application with the shortcut Ctrl-Space. After installing
'anthy', 'Japanese' also appears as an option, and it works 
perfectly.

So for me, this state of affairs is great (you said it should
work even without the gtk) -- as for me, we could close this
bug, but of course I could do some more things for you if it
helps you understand the initial problem I had!!

Thanks for your time and patience,
Matthias
Comment 19 Jens Petersen 2007-08-06 22:57:53 EDT
Ok, wonder how you managed not to install anthy - it is required by
scim-anthy... anyway good you got it to work.

I still wonder why you need scim-gtk since scim-bridge-gtk should be
sufficient.  scim-bridge works better with 3rd party C++ applications
but if you don't use any, you will be fine with scim-gtk.

Note You need to log in before you can comment on or make changes to this bug.