Bug 249945 - removing the packet fails
removing the packet fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: librsvg2 (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-28 07:12 EDT by mail@romal.de
Modified: 2008-10-21 04:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-21 04:17:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mail@romal.de 2007-07-28 07:12:48 EDT
Description of problem:

yum erase librsvg2 fails trying erasing a non-existent folder.

Version-Release number of selected component (if applicable):


How reproducible:

Every time.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

I have a problem in removing the last i386-rpm on my x86_64 rawhide system.
Seems like a problem in the librsvg2-postuninstall-script.


[root@beowulf ~]# yum list *.i386Loading "skip-broken" plugin
development               100% |=========================| 2.1 kB    00:00   
livna-development         100% |=========================| 2.1 kB    00:00   
livna-development-source  100% |=========================| 1.9 kB    00:00   
livna-development-debugin 100% |=========================| 1.9 kB    00:00   
development-debuginfo     100% |=========================| 1.9 kB    00:00   
development-source        100% |=========================| 1.9 kB    00:00   
Excluding Packages in global exclude list
Finished
Installed Packages
librsvg2.i386                            2.16.1-1.fc7           installed     
[root@beowulf ~]# rpm --erase librsvg2.i386ls: Zugriff auf /etc/gtk-2.0/i?86*
nicht möglich: Datei oder Verzeichnis nicht gefunden
/usr/bin/update-gdk-pixbuf-loaders: line 44:
/etc/gtk-2.0/i686-redhat-linux-gnu/gdk-pixbuf.loaders: Datei oder Verzeichnis
nicht gefunden
Fehler: %postun(librsvg2-2.16.1-1.fc7.i386) Skriptlet fehlgeschlagen,
Beenden-Status 1
[root@beowulf ~]# ls /etc/gtk-2.0/
gtkrc  im-multipress.conf  x86_64-redhat-linux-gnu
[root@beowulf ~]#
Comment 1 Bug Zapper 2008-04-04 09:28:13 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 2 mail@romal.de 2008-10-21 04:17:55 EDT
Seems to be fixed in Rawhide.

Note You need to log in before you can comment on or make changes to this bug.