Bug 249951 - wpa_supplicant: $RPM_OPT_FLAGS not honored, empty debuginfo package
Summary: wpa_supplicant: $RPM_OPT_FLAGS not honored, empty debuginfo package
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wpa_supplicant (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-28 13:55 UTC by Ville Skyttä
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 0.5.7-4.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 03:35:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ville Skyttä 2007-07-28 13:55:31 UTC
wpa_supplicant-debuginfo-0.5.7-3.fc8.x86_64 is empty, see
http://fedoraproject.org/wiki/Packaging/Debuginfo

Looking at
http://koji.fedoraproject.org/koji/getfile?taskID=30457&name=build.log it seems
that first, $RPM_OPT_FLAGS are not being honored for the C parts (but they are
for the C++ parts), and the binaries are installed with "install -s" which makes
the debuginfo package useless.  -g is used to compile the C parts so
$RPM_OPT_FLAGS is not the reason for the -debuginfo breakage, but should be
fixed to use those flags nevertheless.

Comment 1 Dan Williams 2007-10-09 21:29:12 UTC
fixed in devel and F7

Comment 2 Fedora Update System 2007-10-11 01:46:20 UTC
wpa_supplicant-0.5.7-4.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wpa_supplicant'

Comment 3 Fedora Update System 2007-11-15 03:35:11 UTC
wpa_supplicant-0.5.7-4.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.