Bug 249953 - no sound Thinkpad T61
Summary: no sound Thinkpad T61
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
low
high
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-28 14:11 UTC by Tom Brinkman
Modified: 2007-11-30 22:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-06 08:31:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tom Brinkman 2007-07-28 14:11:59 UTC
Description of problem: No sound, Thinkpad T61, AD1984 snd chip


Version-Release number of selected component (if applicable):
alsa-lib-1.0.14-0.4.fc8

How reproducible:
no sound since first install F7-live (6/27), then updated to rawhide
 an kept current daily

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
  Sound should work. Tests in kcontrol, sound system never produce sound

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD 
Audio Controller (rev 03)
Thinkpad T61, AD1984 chip
A net search of 'linux ad1984' reveals that the patches (3) for 
this chip should be in current alsa (>= rc4)



Additional info:

Comment 1 Tom Brinkman 2007-07-28 14:47:35 UTC
Forgot;  alsa-utils-1.0.14-0.7.fc8
modprobe.conf:
alias snd-card-0 snd-hda-intel
options snd-card-0 index=0
options snd-hda-intel index=0
options snd-hda-intel model=thinkpad  # I added this

Comment 2 Martin Stransky 2007-07-30 08:13:49 UTC
so this line:

options snd-hda-intel model=thinkpad  # I added this

has no effect, right?

Comment 3 Tom Brinkman 2007-07-30 13:49:01 UTC
Correct, options snd-hda-intel model=thinkpad  has no effect.

I should add I had to manually upgrade alsa-utils-1.0.14-0.7.fc8
alsa-lib-1.0.14-0.4.fc8  using rpm as yum only returned "nothing to do". 
Updated from alsa-lib-1.0.14-0.4.rc3.fc7,  alsa-utils-1.0.14-0.7.rc2.fc7

Comment 4 Martin Stransky 2007-07-30 13:56:35 UTC
T61 isn't supported in ALSA yet, you need add some extra patches to alsa-drivers.

Comment 5 Tom Brinkman 2007-07-30 16:41:18 UTC
According to,
http://www.alsa-project.org/changes/v1-0-14rc4--v1-0-14.txt

"- hda-codec - Add AD1884 / AD1984 codec support
      
      Added the support of AD1884 and AD1984 codec chips.
      Also experimental quirks for Thinkpad T61/X61 laptops with AD1984."

"- hda-codec - Fix wrong mixer controls for AD1984 thinkpad model
      
      Fixed the wrong mixer controls for AD1984 thinkpad model."

  ... it is.  Will F8 support T61/AD1984?

Comment 6 Martin Stransky 2007-07-31 07:20:09 UTC
You can check the 1.0.14 drivers (how-to is here -
http://people.redhat.com/stransky/alsa/) but they still don't work well).

Comment 7 Tom Brinkman 2007-07-31 23:46:33 UTC
   Isn't this y'alls pursuit. IE, "you need add some extra patches to
alsa-drivers."  Didn't you mean "we", Fedora ??  That was the reason for my
filin a BZ to begin with ?  My question stands unanswered, 
   Will F8 support T61/AD1984?




Comment 8 Martin Stransky 2007-08-01 08:01:47 UTC
We use the official ALSA drivers released by ALSA project (the latest are
1.0.14). So if ALSA releases drivers which work fine with AD1984, Fedora (8 or
whatever) will use them and it will support AD1984, too.

Comment 9 Martin Stransky 2007-08-01 08:04:24 UTC
Please note this line from changelog: 

"Also experimental quirks for Thinkpad T61/X61 laptops with AD1984."

it's just an experimental support which will be improved in new drivers.

Comment 11 Marek Mahut 2007-08-01 10:55:14 UTC
I can confirm that the sound is working fine on this laptop using patched alsa
module.


Comment 12 Tom Brinkman 2007-08-01 15:30:07 UTC
    I have sound.  I'M the idiot, it's mostly a PEBKAC. Tho I had been to
thinkwiki (fedora), I read Martin's 'ubuntu' link.  Then dug an old headphone
out of storage an plugged into the external jack. Sound works very well. It's
just the built in speakers that don't work.  Which is also covered at Martin's
link. Usin kmix I can't get them enabled, but I'd just as soon use external
sound anyhow. I've since plugged an woofer/satelites system in.

     I didn't need any of the patches. Rawhide alsa-libs an -utils provide
workin sound for T61/AD1984 an kernel's hda-intel.  Sorry for wastin y'alls
time, an thanks for your patience an attention.

Comment 13 Tom Brinkman 2007-08-04 19:16:26 UTC
  Recent rawide updates, most likely alsa-utils-1.0.14-1.fc8
alsa-lib-1.0.14-1.fc8... I've discovered that now the onboard 
speakers work when the external jack is unplugged. T61/AD1984 
is fully supported.


Comment 14 Martin Stransky 2007-08-06 08:31:06 UTC
okay, closing.

Comment 15 Joel Uckelman 2007-08-07 10:51:19 UTC
I tried those versions of alsa-utils and alsa-lib from Rawhide on my T61 with no
success. Is there some other package additionally which needs to be updated?


Comment 16 Martin Stransky 2007-08-07 10:55:50 UTC
yes, kernel.

Comment 17 Joel Uckelman 2007-08-07 17:24:50 UTC
Thanks!

I can confirm that sound works on my T61 after installing:

kernel-2.6.23-0.71.rc2.fc8
alsa-lib-1.0.14-1.fc8
alsa-utils-1.0.14-1.fc8

Wonderful!

Comment 18 Jan Hutař 2007-10-20 22:40:35 UTC
Please note (this took me some time):

> It's really necessary to leave the modem enabled in the BIOS or the
> hda_intel driver will reutrn azx_get_response timeouts which will
> lead to a non-working soundchip.

-- from: http://thinkwiki.org/wiki/AD1984


Note You need to log in before you can comment on or make changes to this bug.