Bug 249958 - traceroute: useless debuginfo package
Summary: traceroute: useless debuginfo package
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: traceroute   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Martin Bacovsky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Patch
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-28 16:17 UTC by Ville Skyttä
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-23 15:46:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix -debuginfo package (283 bytes, patch)
2007-07-28 16:17 UTC, Ville Skyttä
no flags Details | Diff
Patch for .spec file (262 bytes, patch)
2007-07-30 13:20 UTC, Dmitry Butskoy
no flags Details | Diff

Description Ville Skyttä 2007-07-28 16:17:15 UTC
traceroute's build strips the binary, producing a useless debuginfo package. 
Fix attached, more info at http://fedoraproject.org/wiki/Packaging/Debuginfo

Comment 1 Ville Skyttä 2007-07-28 16:17:15 UTC
Created attachment 160167 [details]
Fix -debuginfo package

Comment 2 Dmitry Butskoy 2007-07-30 13:18:34 UTC
Martin,

Why I did not receive this report as well?

Add me to co-maintainers (I am well familiar with the upstream author :) )



Comment 3 Dmitry Butskoy 2007-07-30 13:20:43 UTC
Created attachment 160243 [details]
Patch for .spec file

No extra patch actually required, just re-define variable at the make
invokation...

Comment 4 Ville Skyttä 2007-07-30 18:41:52 UTC
(In reply to comment #3)
> No extra patch actually required, just re-define variable at the make
> invokation...

Looks like redefining it that way may in some cases overwrite stuff
default.rules adds to LDFLAGS.

Comment 5 Dmitry Butskoy 2007-07-31 11:28:10 UTC
> Looks like redefining it that way may in some cases overwrite stuff
> default.rules adds to LDFLAGS.

Nope.
The "override" gmake directive prevents this. (Moreover, it was initially
intended to do so the clean way.)


Comment 6 Martin Bacovsky 2007-08-23 15:46:41 UTC
LDFLAGS was added to spec file. This should be fixed in RAWHIDE
(traceroute-2.0.7-1.fc8).


Note You need to log in before you can comment on or make changes to this bug.