Bug 249967 - postfix-pflogsumm does not install due to bad dependency information
postfix-pflogsumm does not install due to bad dependency information
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: postfix (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-28 13:49 EDT by George Notaras
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.4.5-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-09 18:42:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Notaras 2007-07-28 13:49:21 EDT
Description of problem:

In the postfix-pflogsumm spec file, the missing "epoch" in the postfix version
is the possible cause of the following conflict, while installing
postfix-pflogsumm in a clean fedora 7 installation.

----------------------------------

# yum list installed postfix
Loading "installonlyn" plugin
Installed Packages
postfix.i386                             2:2.4.3-2.fc7          installed
 
===============================================================
 
# yum install postfix-pflogsumm
Loading "installonlyn" plugin
Setting up Install Process
Parsing package install arguments
fedora                    100% |=========================| 2.1 kB    00:00     
updates                   100% |=========================| 1.9 kB    00:00     
Resolving Dependencies
--> Running transaction check
---> Package postfix-pflogsumm.i386 2:2.4.3-2.fc7 set to be updated
--> Processing Dependency: perl(Date::Calc) for package: postfix-pflogsumm
--> Processing Dependency: postfix = 2.4.3-2.fc7 for package: postfix-pflogsumm
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package perl-Date-Calc.i386 0:5.4-1.2.2.1 set to be updated
---> Package postfix-pflogsumm.i386 2:2.4.3-2.fc7 set to be updated
--> Processing Dependency: perl(Bit::Vector) for package: perl-Date-Calc
--> Processing Dependency: perl(Carp::Clan) for package: perl-Date-Calc
--> Processing Dependency: perl-Bit-Vector >= 6.4 for package: perl-Date-Calc
--> Processing Dependency: postfix = 2.4.3-2.fc7 for package: postfix-pflogsumm
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package perl-Date-Calc.i386 0:5.4-1.2.2.1 set to be updated
---> Package perl-Carp-Clan.noarch 0:5.8-2.fc7 set to be updated
---> Package postfix-pflogsumm.i386 2:2.4.3-2.fc7 set to be updated
---> Package perl-Bit-Vector.i386 0:6.4-2.2.2.1 set to be updated
--> Processing Dependency: postfix = 2.4.3-2.fc7 for package: postfix-pflogsumm
--> Finished Dependency Resolution
Error: Missing Dependency: postfix = 2.4.3-2.fc7 is needed by package
postfix-pflogsumm
Comment 1 George Notaras 2007-07-30 19:51:21 EDT
This bug report was filed under the 'postfix' component, as there is no
'postfix-pflogsumm' component under the 'Fedora' product in the bugzilla menu.
Comment 2 George Notaras 2007-08-20 21:10:32 EDT
Here is some more info.

I install pflogsumm's dependency (perl-Date-Calc)

    yum install perl-Date-Calc

Next, try to install pflogsumm with yum and get the same dependency error:
--------------------------------------------------------------------------
# yum install postfix-pflogsumm
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package postfix-pflogsumm.i386 2:2.4.3-2.fc7 set to be updated
--> Processing Dependency: postfix = 2.4.3-2.fc7 for package: postfix-pflogsumm
--> Finished Dependency Resolution
Error: Missing Dependency: postfix = 2.4.3-2.fc7 is needed by package
postfix-pflogsumm
--------------------------------------------------------------------------

But using rpm directly:

# rpm -ivh
http://download.fedora.redhat.com/pub/fedora/linux/releases/7/Everything/i386/os/Fedora/postfix-pflogsumm-2.3.6-1.i386.rpm

Retrieving
http://download.fedora.redhat.com/pub/fedora/linux/releases/7/Everything/i386/os/Fedora/postfix-pflogsumm-2.3.6-1.i386.rpm
Preparing...                ########################################### [100%]
   1:postfix-pflogsumm      ########################################### [100%]

The package is installed without any issues.
Comment 3 Thomas Woerner 2007-10-04 11:52:59 EDT
Please have a look at postfix-2.4.5-2.fc7 in F-7-testing.
Comment 4 Fedora Update System 2007-10-08 10:58:48 EDT
postfix-2.4.5-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update postfix'
Comment 5 shrek-m 2007-10-25 16:36:13 EDT
yum update fc6 --> f7 is broken
  without postfix-pflogsumm yum is satisfied
  with updates-testing yum is satisfied

i will wait until the package is in "updates", thanks.

# yum update
[...]
Error: Missing Dependency: postfix = 2.4.3-2.fc7 is needed by package
postfix-pflogsumm

# yum update --exclude=postfix-pflogsumm
[...]
Total download size: 1,3 G


$ yum list \*postfix\*
Loading "installonlyn" plugin
Setting up repositories
Reading repository metadata in from local files
Installed Packages
postfix.x86_64                           2:2.3.3-2              installed       
postfix-pflogsumm.x86_64                 2:2.3.3-2              installed       
Available Packages
postfix.x86_64                           2:2.4.3-2.fc7          updates         
postfix.i386                             2:2.4.3-2.fc7          updates         
postfix-pflogsumm.x86_64                 2:2.4.3-2.fc7          updates


# yum --enablerepo=updates-testing update
[...]
Total download size: 1.3 G
Comment 6 shrek-m 2007-10-29 15:41:21 EDT
20071028  fc6 dist upgrade to f7
yum --exclude=postfix\* update

20071029
yum --enablerepo=updates-testing update postfix\*

# rpm -qa \*postfix\* ; yum update ; cat /etc/fedora-release 
postfix-pflogsumm-2.4.5-2.fc7
postfix-2.4.5-2.fc7
Setting up Update Process
No Packages marked for Update
Fedora release 7 (Moonshine)

i see no problems with postfix\* in updates-testing

thanks.
Comment 7 George Notaras 2007-11-01 05:53:34 EDT
I do not understand why we have to install the version from "updates-testing".
Why don't you just fix the SPEC file and roll out a new release of the same
version of postfix?

I tried the following on a new fedora installation:

# yum --enablerepo=updates-testing install postfix-pflogsumm

No dependency issues.

But why should I beta-test a new postfix version in order to use a Perl script?
Could you please just fix that SPEC file and stop complicate things?

It's been 3+ months since I initially reported this.
Comment 8 Fedora Update System 2007-11-09 18:42:14 EST
postfix-2.4.5-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.