Bug 249978 - rp-pppoe not built with $RPM_OPT_FLAGS
Summary: rp-pppoe not built with $RPM_OPT_FLAGS
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rp-pppoe   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: bzcl34nup
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-28 20:44 UTC by Ville Skyttä
Modified: 2008-04-10 09:17 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-10 09:17:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Build with $RPM_OPT_FLAGS, run autoconf in %prep, not %build (1002 bytes, patch)
2008-04-09 19:51 UTC, Ville Skyttä
no flags Details | Diff

Description Ville Skyttä 2007-07-28 20:44:33 UTC
rp-pppoe is not built with $RPM_OPT_FLAGS.
Fix: CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE" %configure

Comment 1 Bug Zapper 2008-04-04 13:29:27 UTC
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Comment 2 Ville Skyttä 2008-04-09 19:51:06 UTC
Created attachment 301888 [details]
Build with $RPM_OPT_FLAGS, run autoconf in %prep, not %build

Ping?  This should be a no-brainer, I'd commit it myself if the ACLs would let
me.

Comment 3 Ville Skyttä 2008-04-09 19:52:08 UTC
(Cc'ing Karsten who has asked commit access in packagedb.)

Comment 4 Karsten Hopp 2008-04-10 09:17:53 UTC
I've added the RPM_OPT_FLAGS part of your patch, but not the autoconf part.
I've looked up in our guidelines and haven't found anything that mandates this
so it looks like this is up to the maintainer to decide.


Note You need to log in before you can comment on or make changes to this bug.