Bug 249988 - Sound output is not stereo until volume slider is moved
Summary: Sound output is not stereo until volume slider is moved
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: alsa-lib   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-29 01:37 UTC by Chris
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-15 13:46:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sound Config log (40.29 KB, text/plain)
2007-08-17 05:54 UTC, Chris
no flags Details

Description Chris 2007-07-29 01:37:06 UTC
Description of problem: When I first start up and login, there is only sound
coming out of one channel.  Until the volume slider is moved, it is stuck like
that.  Once the slider in the mixer is moved, sound comes out of both left and
right channels.


Version-Release number of selected component (if applicable): 1.0.14-0.4.rc3.fc7


How reproducible: Happens every time I start up the computer and login


Steps to Reproduce:
1. Start up and login
2. Play something and listen to sound
3. Move the volume slider and listen again, sound is now stereo
  
Actual results: Sound is not stereo until slider is moved.


Expected results: Sound should always be stereo since the channels are linked
and they are not muted.


Additional info:

Comment 1 Chris 2007-07-29 01:41:24 UTC
Here is a link to Launchpad report, as I had this problem in Ubuntu Feisty as
well.  They have linux-source-2.6.20 marked as the affected package, but since
Fedora 7 uses 2.6.22.x that needs to be changed.

https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/110481

Comment 2 Martin Stransky 2007-08-15 15:29:45 UTC
Aha, okay. There's an updated kernel package for F7 with alsa-drivers 1.0.14.
Anyway, what channel do you have to move? There's a command line utility nammed
alsaunmute what should set all channels to the default values. Does it do that?

Anyway, can you please attach /root/scsconfig.log? It can be generated by
system-config-soundcard.

Comment 3 Chris 2007-08-17 05:54:12 UTC
Created attachment 161716 [details]
Sound Config log

Comment 4 Chris 2007-08-17 05:57:00 UTC
The channel I have to move is "PCM".  I ran the command "alsaunmute 0", and that
made the volume louder and unmuted the left channel.  However it doesn't work if
I reboot, I have to do it again just like moving the volume slider.

Comment 5 Martin Stransky 2007-08-20 11:18:32 UTC
Aha. Is the volume of "PCM" preserved during boot? If not, that could be a dupe
of Bug 247468.

Anyway, please report it at upstream (www.alsa-project.org) and file a bug
there. This bug should be fixed there for all distros.

Comment 6 Chris 2007-09-19 21:53:10 UTC
Hi Martin, sorry for the delayed response.  The PCM level isn't preserved when I
reboot, it goes back to 50%.  I believe with the updated alsa-drivers, that the
stereo problem has been taken care of, so this bug can be closed and set to
fixed.  I will contribute to Bug 24746 to help with that one.  Thanks for all
your help!

Comment 7 Martin Stransky 2007-10-15 13:46:42 UTC
okay, closing.


Note You need to log in before you can comment on or make changes to this bug.