Bug 249989 - yum tries to remove rpms from file:// repo directory
yum tries to remove rpms from file:// repo directory
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-28 21:51 EDT by Roland McGrath
Modified: 2014-01-21 17:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-29 02:07:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roland McGrath 2007-07-28 21:51:40 EDT
Description of problem:

When some repos/mirrorlist dirs are file:/// urls, yum now tries to remove the
original rpm files from the repo (as if they were its cache files, perhaps).
Fortunately my nfs-mounted repo is exported read-only, so it can't do any harm.
 But it's so, so wrong.

This is a new problem that appeared in rawhide not too long ago, f7 et al are  fine.

Version-Release number of selected component (if applicable):
yum-3.2.2-3.fc8

How reproducible:
100%

Steps to Reproduce:
1.have your mirrorlist url return a file:/// url for a repo
2.yum upgrade something
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Seth Vidal 2007-07-29 01:54:17 EDT
confirmed it happens - not sure why it just started happening, though. Nothing
in it seems to be new.
Comment 2 Seth Vidal 2007-07-29 02:06:25 EDT
nevermind - I figured out what changed and caused it and fixed it. Will be out
in 3.2.3.


Thanks.
Comment 3 Fedora Update System 2007-08-24 01:34:18 EDT
yum-3.2.3-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.