Bug 250005 - Lots of USB control queue full messages
Lots of USB control queue full messages
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-29 06:38 EDT by Bernd Bartmann
Modified: 2008-01-10 14:21 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.23.9-85.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-10 14:21:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
contents of /proc/bus/usb/devices (3.97 KB, text/plain)
2007-10-02 17:19 EDT, Bernd Bartmann
no flags Details

  None (edit)
Description Bernd Bartmann 2007-07-29 06:38:16 EDT
Description of problem:
I'm seeing lots of these messages in /var/log/messages:
Jul 28 19:28:57 riker kernel: drivers/hid/usbhid/hid-core.c: control queue full
Jul 28 19:29:40 riker last message repeated 4 times
Jul 28 19:30:49 riker last message repeated 4 times
Jul 28 19:32:09 riker last message repeated 8 times
Jul 28 19:33:29 riker last message repeated 8 times
Jul 28 19:34:30 riker last message repeated 6 times

I notice these messages at least since kernel-2.6.22.1-27.fc7 and they are still
in kernel-2.6.22.1-27.fc7.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Christopher Brown 2007-09-21 08:33:11 EDT
Hello Bernd,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris
Comment 2 Bernd Bartmann 2007-10-02 14:38:17 EDT
Sorry for the late response, but I've been on vacation for a while. 

kernel-2.6.22.9-91.fc7 still shows this messages. The system that I checked is
FC7 fully updated. Also, the messages are not there every day, i.e. yesterday I
had lots of them in /var/log/messages, but today I haven't found a single one yet.
Comment 3 Pete Zaitcev 2007-10-02 16:59:45 EDT
I haven't looked at this yet, sorry. At first glance, a few explanations
are possible:
 - An application is bombing HID through /dev/kbd or other means
 - Broken device which stalls control messages
 - A loop in kernel where up-stack events trigger controls (a kernel bug)
 - A race which causes the queue to get corrupt (a kernel bug)

HID almost has no diagnostics at all, I really do not know what to do
short of trying specially instrumented kernels.

What is connected to the system? Please attach /proc/bus/usb/devices.
Comment 4 Bernd Bartmann 2007-10-02 17:19:05 EDT
Created attachment 214041 [details]
contents of /proc/bus/usb/devices
Comment 5 Christopher Brown 2008-01-10 13:52:29 EST
Bernd,

Could I trouble you for an update? Are you still having this issue?
Comment 6 Bernd Bartmann 2008-01-10 13:56:51 EST
Seems to be fixed in the meantime. The system is now on F8 fully updated and I
don't see such messages anymore.
Comment 7 Christopher Brown 2008-01-10 14:21:37 EST
(In reply to comment #6)
> Seems to be fixed in the meantime. The system is now on F8 fully updated and I
> don't see such messages anymore.

Good to hear Bernd. I'll close to reflect that but please re-open if the issue
returns. Thanks for filing the bug.

Note You need to log in before you can comment on or make changes to this bug.