Bug 250006 - Broken run-time dependencies in EPEL 4
Broken run-time dependencies in EPEL 4
Status: CLOSED RAWHIDE
Product: Fedora EPEL
Classification: Fedora
Component: mimedefang (Show other bugs)
el4
All Linux
low Severity medium
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
:
Depends On: 250007
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-29 07:22 EDT by Robert Scheck
Modified: 2007-08-29 16:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-29 16:09:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2007-07-29 07:22:54 EDT
Description of problem:
mimedefang has broken dependencies in the EPEL:
On ppc:
        mimedefang - 2.62-2.el4.ppc requires perl(MIME::Tools) >= 0:5.410
        mimedefang - 2.62-2.el4.ppc requires perl(MIME::Base64) >= 0:3.03
        mimedefang - 2.62-2.el4.ppc requires perl(MIME::Parser)
        mimedefang - 2.62-2.el4.ppc requires perl(MIME::Words)
On x86_64:
        mimedefang - 2.62-2.el4.x86_64 requires perl(MIME::Tools) >= 0:5.410
        mimedefang - 2.62-2.el4.x86_64 requires perl(MIME::Base64) >= 0:3.03
        mimedefang - 2.62-2.el4.x86_64 requires perl(MIME::Parser)
        mimedefang - 2.62-2.el4.x86_64 requires perl(MIME::Words)
On i386:
        mimedefang - 2.62-2.el4.i386 requires perl(MIME::Tools) >= 0:5.410
        mimedefang - 2.62-2.el4.i386 requires perl(MIME::Base64) >= 0:3.03
        mimedefang - 2.62-2.el4.i386 requires perl(MIME::Parser)
        mimedefang - 2.62-2.el4.i386 requires perl(MIME::Words)
Please resolve this as soon as possible.

Version-Release number of selected component (if applicable):
mimedefang-2.62-2

How reproducible:
Everytime.

Actual results:
Broken run-time dependencies in EPEL 4

Expected results:
Working MIMEDefang and satisfied run-time dependencies.
Comment 1 Robert Scheck 2007-08-29 16:09:16 EDT
This problem cant be solved really. MIMEDefang depends on MIME::Base64 which 
is too new for Red Hat Enterprise Linux 4. Maintaining a private MIME::Base64 
inside of the MIMEDefang package is not what I would like to see and do. If 
somebody really needs MIMEDefang for Red Hat Enterprise Linux 4, we have to 
decide, what is best. Maybe we can use an older version of MIMEDefang or so.

Note You need to log in before you can comment on or make changes to this bug.