Bug 250009 - kmail indicates old mail as unread
kmail indicates old mail as unread
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-29 07:49 EDT by Jaroslaw Gorny
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 3.5.7-10.svn20070926.ent.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-24 03:03:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 147509 None None None Never

  None (edit)
Description Jaroslaw Gorny 2007-07-29 07:49:56 EDT
Description of problem:
Kmail (no matter if run as a separate app or from kontact) since couple of 
days indicates some read mail as new (unread).

Version-Release number of selected component (if applicable):
kdepim-3.5.7-3


How reproducible:
ALWAYS

Steps to Reproduce:
1. open kmail
2. go to folder 'Foo' containing some mail from last 3-4 days
3. read all the mail in that folder, so that unread = 0
4. go to folder 'Bar'
5. go back to folder 'Foo' and notice that unread > 0 (mail You've just read 
couple of seconds ago, are again marked as unread)
  
Actual results:
Previously read mail is marked as unread.

Expected results:
Previously read mail should not be re-marked as unread.

Additional info:
This messages are no more than 3-4 days old - but not all messages from this 
period are re-marked as new. And I can't figure the key to figure out 
the 'algorithm'.
Comment 1 Ville Skyttä 2007-07-29 12:41:39 EDT
I'm seeing this too, and haven't found out what might be triggering it either. 
I didn't notice it before KDE 3.5.7, and not even immediately afterwards; I
think it has started happening in the past week or two.
Comment 2 Jaroslaw Gorny 2007-07-29 13:40:24 EDT
(In reply to comment #1)
> I'm seeing this too, and haven't found out what might be triggering it 
either. 
> I didn't notice it before KDE 3.5.7, and not even immediately afterwards; I
> think it has started happening in the past week or two.

Exactly the same here. This issue hit me couple of days after I've upgraded to 
kde 3.5.7.

I did one thing couple of hours ago, and since then I don't see this issue:
for each mail folder:
- RMB -> "mark all messages as read"
- RMB -> "compress folder"

But it is difficult to say if it really fixes this behaviour - 4 hours is to 
little to be sure ;)
Comment 3 Rex Dieter 2007-07-29 14:37:12 EDT
This is something worthy of pushing/reporting upstream.  Anyone do that yet?
Comment 4 Jaroslaw Gorny 2007-07-29 14:52:47 EDT
(In reply to comment #3)
> This is something worthy of pushing/reporting upstream.  Anyone do that yet?

I haven't reported it upstream. Of course I can do this, but I'm not 
subscribed on kde* lists. Please, let me know: would You be so kind to report 
it, or I should do it?
Comment 5 Rex Dieter 2007-07-29 14:59:23 EDT
the process works best if you report the problems yourself, in case upstream
devs have questions, require feedback, suggest troubleshooting, etc...
Comment 6 Jaroslaw Gorny 2007-07-29 15:55:38 EDT
Seems like this is already in KDE's bugzilla:
http://bugs.kde.org/show_bug.cgi?id=147509
Comment 7 Ville Skyttä 2007-07-29 16:55:51 EDT
So the two kde* F-7 updates in a week or so are kde-settings and kdelibs.  I'll
see if I catch this bug occurring again with the latest versions, if yes, then
backing down to the previous versions and see if I see it happening with them as
well.
Comment 8 Ville Skyttä 2007-07-30 16:15:45 EDT
Got it happening with the old kdelibs too.  After that, went back to the current
one, ran "Compact folder" on my Inbox, and this stuff hasn't happened since for
any folder (in two or so hours).  My Inbox had some unread items at the time I
compacted it and still has.
Comment 9 Jaroslaw Gorny 2007-07-30 16:51:53 EDT
(In reply to comment #8)
> ran "Compact folder" on my Inbox, and this stuff hasn't happened since for
> any folder (in two or so hours).  My Inbox had some unread items at the time 
> I compacted it and still has.

Yes, I've described it in comment #2 and more detailed check is reported in 
comment #11 to referenced bug from KDE's bugzilla. 
(http://bugs.kde.org/show_bug.cgi?id=147509#c11)
Comment 10 Ville Skyttä 2007-07-30 17:09:57 EDT
Sure, but there's a few differences between our reports: I didn't do the "mark
all messages as read" step that you described for any folder, and I compacted
only my inbox, no other folders, and doing only that seems to have fixed things
for all folders.
Comment 11 David Anderson 2007-07-31 09:17:32 EDT
Same here. Fully update FC7 system.
Comment 12 Ville Skyttä 2007-07-31 11:38:36 EDT
The steps I took helped only for a little while.  Now manual compacting needs to
be done always before switching from a folder to another one to preserve the
state of read mails.

Also, kmail has eaten all "important" and "todo" marks from all my mails, and
new marks disappears from newly marked mails as soon as I switch folders. 
Compacting does not help with that, the marks just won't stick.

OUCH.
Comment 13 Jaroslaw Gorny 2007-07-31 17:21:16 EDT
(In reply to comment #12)
> Also, kmail has eaten all "important" and "todo" marks from all my mails, 
> and new marks disappears from newly marked mails as soon as I switch 
> folders. 
> Compacting does not help with that, the marks just won't stick.

I confirm that behaviour - the same here.
Comment 14 Ville Skyttä 2007-08-02 14:27:55 EDT
I have no clue what happened - before my last report I stopped trying to tinker
with my ~/.kde/share/apps/kmail, and suddenly today things started working
again.  No more read mails reappearing as unread, and marking work again. 
Here's the set of updates installed between when I gave up and today when things
started working:

alsa-lib-1.0.14-1.fc7.i386
alsa-lib-1.0.14-1.fc7.x86_64
authconfig-5.3.15-1.fc7.x86_64.rpm
authconfig-gtk-5.3.15-1.fc7.x86_64.rpm
ctapi-common-1.1-2.fc7.x86_64.rpm
eel2-2.18.3-1.fc7.x86_64.rpm
glib2-2.12.13-1.fc7.i386.rpm
glib2-2.12.13-1.fc7.x86_64.rpm
gtk2-2.10.14-3.fc7.i386.rpm
gtk2-2.10.14-3.fc7.x86_64.rpm
libgssapi-0.11-1.fc7.x86_64.rpm
nfs-utils-1.1.0-1.fc7.x86_64.rpm
nfs-utils-lib-1.0.8-10.fc7.x86_64.rpm

...as well as kernel-2.6.22.1-41.fc7.x86_64, but I tried booting with -33 too
and it works with it as well.  Go figure.
Comment 15 Jaroslaw Gorny 2007-08-02 17:54:36 EDT
(In reply to comment #14)
> I have no clue what happened - before my last report I stopped trying to 
tinker
> with my ~/.kde/share/apps/kmail, and suddenly today things started working
> again.
(...)

Ville, after this upgrade kmail works OK here too.
And I've noticed some 'weird' things that IMHO _ARE_ related to this bug.
All of them are connected with system time.

1. After upgrade, when I rebooted system, during startup fsck told me sth. 
like:
"(...) node write time is in future, FIXED"

2. In /var/log/messages I see that before upgrade system time was messed up! 
Eg. entries from today's first boot (before upgrade) are dated 1h 35m in the 
future. After upgrade and reboot /var/log/messages shows correct date/time.
But I'm _SURE_ that during this all time I had KMail issues (last couple of 
days) my "user visible" clock (on kde's bar) was showing time correctly.

3. Mail sent from logwatch@localhost was also wrongly dated.

4. KMail's issues _may_ be related to this, because several messages I've 
recived were anormal, eg. some mail from "yesterday" had "yesterday" in date 
column, but some other - "wednesday".
Of course, it was wednesday yesterday, but it is not normal to mark 
differently mail from the same day.
Comment 16 Fedora Update System 2007-10-10 21:44:20 EDT
kdepim-3.5.7-10.svn20070926.ent.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdepim'
Comment 17 Fedora Update System 2007-10-24 03:03:02 EDT
kdepim-3.5.7-10.svn20070926.ent.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.