Bug 250021 - imagemagick does not conver some file to jpeg
imagemagick does not conver some file to jpeg
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-29 13:00 EDT by Need Real Name
Modified: 2008-08-04 11:11 EDT (History)
2 users (show)

See Also:
Fixed In Version: F-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-04 11:11:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
original pdf (128.14 KB, application/pdf)
2007-07-29 13:02 EDT, Need Real Name
no flags Details
result of pdf2ps z.pdf - |convert - cc.jpeg (converted OK) (135.99 KB, image/jpeg)
2007-07-29 13:03 EDT, Need Real Name
no flags Details
strace of convert z.pdf x.jpeg (68.92 KB, text/plain)
2007-07-29 13:05 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2007-07-29 13:00:37 EDT
using 
ImageMagick-6.3.2.9-3.i386.rpm            
ImageMagick-perl-6.3.2.9-3.i386.rpm       
ghostscript-gtk-8.60-0.svn8117.2.i386.rpm  
ghostscript-devel-8.60-0.svn8117.2.i386.rpm  
ghostscript-8.60-0.svn8117.2.i386.rpm   

from development tree I get convert z.pdf x.jpeg
Error: /ioerror in --filter--
Operand stack:
   --dict:12/21(L)--   false   false   --dict:11/19(L)--   --nostringval--  
--nostringval--   --dict:0/0(L)--
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--  
--nostringval--   2   %stopped_push   --nostringval--   --nostringval--  
--nostringval--   false   1   %stopped_push   1889   1   3   %oparray_pop   1888
  1   3   %oparray_pop   1872   1   3   %oparray_pop   --nostringval--  
--nostringval--   2   1 1   --nostringval--   %for_pos_int_continue  
--nostringval--   --nostringval--   --nostringval--   --nostringval--  
%array_continue   --nostringval--   false   1   %stopped_push   --nostringval--
  %loop_continue   --nostringval--   130138   --nostringval--   --nostringval--
  --nostringval--   --nostringval--   --nostringval--   --nostringval--  
%array_continue   --nostringval--   1749   8   13   %oparray_pop
Dictionary stack:
   --dict:1152/1684(ro)(G)--   --dict:2/20(G)--   --dict:75/200(L)--  
--dict:75/200(L)--   --dict:106/127(ro)(G)--   --dict:274/300(ro)(G)--  
--dict:21/25(L)--   --dict:4/6(L)--   --dict:20/20(L)--   --dict:1/1(ro)(G)--  
--dict:1/1(ro)(G)--   --dict:1/1(ro)(G)--   --dict:7/17(L)--
Current allocation mode is local
Last OS error: 2
GPL Ghostscript SVN PRE-RELEASE 8.60: Unrecoverable error, exit code 1
convert: Postscript delegate failed `z.pdf'.
convert: missing an image filename `x.jpeg'.


In the same time
pdf2ps z.pdf - |convert - cc.jpeg

work OK
Comment 1 Need Real Name 2007-07-29 13:02:03 EDT
Created attachment 160197 [details]
original pdf
Comment 2 Need Real Name 2007-07-29 13:03:15 EDT
Created attachment 160198 [details]
result of pdf2ps z.pdf - |convert - cc.jpeg (converted OK)
Comment 3 Need Real Name 2007-07-29 13:05:04 EDT
Created attachment 160199 [details]
strace of convert z.pdf x.jpeg

strace of convert z.pdf x.jpeg
Comment 4 Need Real Name 2007-07-29 13:06:03 EDT
Other .pdf files get converted OK
Comment 5 Norm Murray 2007-09-23 20:31:17 EDT
I'm unable to reproduce this myself, and even if I could, it looks like it's
blowing up for you in ghostscript, which ImageMagick uses as a helper. Moving to
ghostscript component
Comment 6 Need Real Name 2007-09-24 00:28:56 EDT
Using 
ImageMagick-c++-devel-6.3.2.9-3
ImageMagick-c++-6.3.2.9-3
ImageMagick-perl-6.3.2.9-3
ImageMagick-devel-6.3.2.9-3
ImageMagick-6.3.2.9-3

ghostscript-devel-8.15.4-1.fc6
ghostscript-8.15.4-1.fc6
ghostscript-fonts-5.50-13.1.1

I do not get the trace above, but the result of 

convert z.pdf x.jpeg

is z.jpeg image, which cannot be viewed, because of errors.
The ImageMagick-6.3.2.9-3 produced the trace above.
Comment 7 Tim Waugh 2007-09-25 07:46:15 EDT
comment #6 seems to refer to a completely separate bug -- please file a separate
bug report for it.

Regarding this bug report, please upgrade to current ghostscript (8.60-2.fc8)
and let us know whether the problem is still there.
Comment 8 Bug Zapper 2008-04-04 09:30:12 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 9 Tim Waugh 2008-08-04 11:11:40 EDT
Seems to work fine in Fedora 8.

Note You need to log in before you can comment on or make changes to this bug.