Bug 25003 - postun problem in upgrade
postun problem in upgrade
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
David Lawrence
Florence RC-1
:
: 25084 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-25 23:09 EST by David Lawrence
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-29 19:00:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Tattersall 2001-01-25 23:09:46 EST
In an everything update from RHL7.0, the following message appears in
upgrade.log:
Upgrading LPRng.
execution of %postun scriptlet from LPRng-3.6.24-2 failed, exit status 127

Crutcher has been looking at this, but has not yet found a solution.
Comment 1 Tim Waugh 2001-01-26 05:34:13 EST
Looks like this to me:

preun: LPRng removes /etc/rc.d/init.d/lpd
new LPRng is installed, which does not have an lpd initscript
postun: old LPRng tries to exec /etc/rc.d/init.d/lpd, which isn't there any
more.

Easy fix would be to give LPRng a prereq for printconf.
Comment 2 Tim Waugh 2001-01-26 05:34:44 EST
(because printconf is the package that owns the initscript now)
Comment 3 Glen Foster 2001-01-29 18:38:40 EST
*** Bug 25084 has been marked as a duplicate of this bug. ***
Comment 4 Glen Foster 2001-01-29 19:00:53 EST
This defect is considered MUST-FIX for Florence Release-Candidate #1
Comment 5 Crutcher Dunnavant 2001-02-01 16:56:07 EST
Right, I'm not happy with the resolution of this, but it is fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.