Bug 250032 - dhclient does not retrieve ip address
dhclient does not retrieve ip address
Status: CLOSED DUPLICATE of bug 250003
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-29 16:16 EDT by Evaldas
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 250003
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-01 15:28:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Evaldas 2007-07-29 16:16:33 EDT
Description of problem: dhclient  does not retrieve ip address


Version-Release number of selected component (if applicable):
kernel 2.6.22.1-33.fc7
dhclient-3.0.5-38.fc7

How reproducible:
dhclient -1 eth0
Internet Systems Consortium DHCP Client V3.0.5-RedHat
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/
Listening on LPF/eth0/00:c0:9f:52:01:dc
Sending on   LPF/eth0/00:c0:9f:52:01:dc
Sending on   Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
DHCPOFFER from 192.168.2.254
and stops

on system boot it stops at retrieving ip
--------
it works fine with kernel 2.6.22.1-27.fc7
Comment 1 Evaldas 2007-07-29 17:07:58 EDT
a problem with dhcp-3.0.3-28 in FC5
if a fixed ip get into Address ranges, then everything works
Comment 2 Krzysztof Rzadca 2007-07-30 13:06:39 EDT
I confirm this bug with the same kernel/dhclient version. dhclient does not work
on both network interfaces (iwl3945 wifi and r8169 ethernet).
Comment 3 Răzvan Sandu 2007-08-01 06:23:02 EDT
Hello,

This is happening to me too, on a number of different machines.

Others are experimenting this bug too, please see
http://www.fedoraforum.org/forum/showthread.php?t=162082

I'd rather change this to high priority, because it can render one's system
unusable (or, at least, you may easily lose remote control of it).

I suspect this is not selinux-related, because I did a full relabelling and it
won't help.


Regards,
Răzvan
Comment 4 Evaldas 2007-08-01 15:21:35 EDT
it works fine with kernel 2.6.22.1-41.fc7
(selinux is switched off in my fedora)

thanks
Comment 5 Chuck Ebbert 2007-08-01 15:29:03 EDT
*** This bug has been marked as a duplicate of 250003 ***

*** This bug has been marked as a duplicate of 250003 ***

Note You need to log in before you can comment on or make changes to this bug.