Bug 250034 - 2.6.22.1-33.fc7 breaks ethernet
2.6.22.1-33.fc7 breaks ethernet
Status: CLOSED DUPLICATE of bug 250003
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-29 17:21 EDT by Joe
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-01 07:01:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe 2007-07-29 17:21:59 EDT
Description of problem:
I updated from 2.6.22.1-27.fc7 to 2.6.22.1-33.fc7, after reboot to the new
kernel version my statically assigned ethernet connection was not working.

Version-Release number of selected component (if applicable):
2.6.22.1-33.fc7

How reproducible:


Steps to Reproduce:
1.boot kernel 2.6.22.1-33.fc7
2. attempt to use ethernet card
3.
  
Actual results:
network failed to work

Expected results:
network works as expected.

Additional info: r8169 gigabit module on Tforce p965 rev 5.0
upgraded to 2.6.22.1-41.fc7, problem not present.

this is potentially similar to bugs: 249886,250032 except I had a static IP
address assigned.
Comment 1 Vladimir Kotal 2007-07-29 18:12:58 EDT
Same thing here. 2.6.22.1-33 breaks Eternet (DHCP in my case). The problem is
not present in 2.6.21-1.3228.fc7. Someone should remove 2.6.22.1-33.fc7 from the
updates.

Let me know if you need dmesg output of more info.
Comment 2 Vladimir Kotal 2007-07-29 18:14:51 EDT
Relevant part of dmesg with working kernel:

eth0: RealTek RTL8139 at 0xf88e4000, 00:0d:61:7c:a5:52, IRQ 21
eth0:  Identified 8139 chip type 'RTL-8100B/8139D'
eth0: link up, 100Mbps, full-duplex, lpa 0xC5E1
eth0: no IPv6 routers present
Comment 3 Milan Kerslager 2007-08-01 07:01:09 EDT
The latest kernel-2.6.22.1-41.fc7 solves the problem. Please reopen or create
new bugreport if your problem persist. See bug #250003 for more info.

*** This bug has been marked as a duplicate of 250003 ***

Note You need to log in before you can comment on or make changes to this bug.