Bug 250054 - scim isn't working on x86_64 Fedora 7
scim isn't working on x86_64 Fedora 7
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
7
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-30 03:08 EDT by min gyu Jeon
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-10 20:50:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description min gyu Jeon 2007-07-30 03:08:06 EDT
Description of problem:
 I have installed Fedora 7 on two platform i386 and x86_64.
scim is working well on i386 platform but is not working on x86_64 platform.
I have installed two system same condition also scim configuration is same.
First, scim was run automatically at system booting time on x86_64.
Second, When I ran scim manually in terminal application, that is run but is 
not working correctly. I could find scim icon at top-right in screen.  
I could see a menu by mouse right click on scim icon but I couldn't see menu by 
mouse left click on scim icon.  

Version-Release number of selected component (if applicable):
i386 system 

How reproducible:
I think if you install fedora 7 on x86_64 platform, you will meet same problem.


Steps to Reproduce:
1. Install all pakages Fedora 7 on x86_64 platform.
2. Language : Korean
3. Keyboard : English (USA)
  
Actual results:
I can't input Korean Language because scim is not working correctly.

Expected results:
Input Korean language by a application like terminal, Firefox..
* scim is working well on i386 platform.

Additional info:
Comment 1 min gyu Jeon 2007-07-30 03:12:10 EDT
scim version
 scim-1.4.5-21.fc7
Comment 2 Jens Petersen 2007-07-30 21:25:35 EDT
Both machines were installed in Korean and system locale is Korean?

SCIM works ok for me on my F7 x86_64 box.
Comment 3 min gyu Jeon 2007-07-30 22:01:18 EDT
Yes, That is Korean.
Also, locale value is same on x86_64 and i386 mahines by locale command.
Comment 4 min gyu Jeon 2007-07-30 22:27:59 EDT
Sorry, I will try to send no email directly.
I am usgin bugzilla first.
Comment 5 Jens Petersen 2007-09-13 03:25:35 EDT
Any more information on this?
Comment 6 Jens Petersen 2007-10-09 03:18:27 EDT
What is the output of "rpm -qa --qf "%{name}.%{arch}\\n" scim\* | sort"
on the x86_64?

Or did you already solve this?
Comment 7 min gyu Jeon 2007-10-10 20:50:57 EDT
No, I didn't solve this.

I hope to add comment in C source file using Korean.
Now, I am adding comment in C source file using English.
I postpone to solve that problem. 

Thank you.
Comment 8 Jens Petersen 2007-10-10 20:57:49 EDT
Ok I would make sure that you have both scim-bridge-gtk.i386 and
scim-bridge-gtk.x86_64 installed (or scim-gtk.i386 and scim-gtk.x86_64).

Note You need to log in before you can comment on or make changes to this bug.