Bug 250058 - ifup-eth script does not work corretly with mixed bond/native network configuration
Summary: ifup-eth script does not work corretly with mixed bond/native network configu...
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: initscripts   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
: ---
Assignee: initscripts Maintenance Team
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-30 07:25 UTC by David Kostal
Modified: 2010-02-11 21:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-11 21:40:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ifup-eth patch (425 bytes, patch)
2007-07-30 07:25 UTC, David Kostal
no flags Details | Diff

Description David Kostal 2007-07-30 07:25:46 UTC
Description of problem:
If the system has both bond and native (eth) network interfaces configured, then
after the system boot all bonding slaves are down.

Version-Release number of selected component (if applicable):
initscripts-8.45.14.EL-1.el5.centos.1

How reproducible:
Allways

Steps to Reproduce:
1. Configure bond0 with at least one slave (eg. eth0 and eth1). Configure
(another) ethernet interface (eg. etth2).
2. boot the system

  
Actual results:
bond0 and eth3 are up, eth0 and eth1 are down.

Expected results:
All bond0, eth0, eth1 and eth2 should be up.

Additional info:
In the ifup-eth script there is a section which shuts down the "slave"
interfaces. Commenting this command causes everything to start up normally.
Patch is included, although I'm not sure whether it's the best place to fix.

Comment 1 David Kostal 2007-07-30 07:25:46 UTC
Created attachment 160219 [details]
ifup-eth patch

Comment 2 Bill Nottingham 2009-03-18 21:23:41 UTC
I apologize for the extremely awful response time here.

Does this persist with current RHEL 5 updates? There have been various updates to bonding support in the interim. Also, your configuration might help.

Comment 3 Bill Nottingham 2010-02-11 21:40:49 UTC
Closing due to no response, apologies.


Note You need to log in before you can comment on or make changes to this bug.