Bug 250060 - shutting down of bonding interface loops forever under special conditions
shutting down of bonding interface loops forever under special conditions
Status: CLOSED DUPLICATE of bug 448837
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: initscripts (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: initscripts Maintenance Team
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2007-07-30 03:40 EDT by David Kostal
Modified: 2009-03-18 17:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-03-18 17:19:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description David Kostal 2007-07-30 03:40:45 EDT
Description of problem:
Shuttind down (ifdown) of bonding interface with one link down can result in
infinite loop. If complete reboot/poweroff is being ewxecuted, the machine will
not shut down.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Configure bond0 and bond1 (balance-alb  in my case), with eth0,eth1 in bond0
and eth2,eth3 in bond1. eth2 has no physical link, other network cards are
2. Start up bond0 and bond1
3. Try to shutdown bond1 (or do complete poweroff)
Actual results:
Machine appears to hang while shutting down bond1. In fact it's executing
"ifdown eth2", "ifdown eth3", "ifdown eth2",... in a loop.

Expected results:
bond1 should shut down instantly.

Additional info:
It's is possible that this error appears with bond0 configured only if there was
also one (probably the first) slave without link. However it was tested only
with bond0 and bond1 configuration by me and therefore also the steps to
reproduce include both bond0 and bond1.

The scenario also caused "freeze" of the system during shutdown and machine had
to be resetted with a button.

If both slave devices are with link, there is no problem and everything works as

The problem was fixed instantly after removing HWADDR= lines from slave devices'
configurations. Unfortunately this also caused renaming of the eth devices on
next boot/after reloading ethernet card driver.
Comment 1 David Kostal 2007-08-22 02:16:23 EDT
Were you able to reproduce it? Are there any news on this issue? Thanks.
Comment 2 Bill Nottingham 2007-08-29 13:09:52 EDT
No updates as of now.
Comment 3 Bill Nottingham 2009-03-18 17:19:37 EDT
I believe this will be fixed in a future RHEL 4 update.

*** This bug has been marked as a duplicate of bug 448837 ***

Note You need to log in before you can comment on or make changes to this bug.