Bug 250068 - strace doesn't show new futex calls
strace doesn't show new futex calls
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-kernel (Show other bugs)
1.0
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Arnaldo Carvalho de Melo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-30 06:46 EDT by IBM Bug Proxy
Modified: 2008-02-27 14:57 EST (History)
1 user (show)

See Also:
Fixed In Version: strace-4.5.16-1el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-08 14:24:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix the problem in strace (1004 bytes, patch)
2007-07-30 06:46 EDT, IBM Bug Proxy
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 36706 None None None Never

  None (edit)
Description IBM Bug Proxy 2007-07-30 06:46:56 EDT
LTC Owner is: sripathi@in.ibm.com
LTC Originator is: sripathi@in.ibm.com


strace does not understand PI related futex calls. strace output looks like this
for such calls:

11733 futex(0x602a20, 0x7 /* FUTEX_??? */, 11733 <unfinished ...>
11734 futex(0x602a20, 0x6 /* FUTEX_??? */, 1 <unfinished ...>
11732 <... futex resumed> )             = 0
11733 <... futex resumed> )             = 0

OS: RHEL5.
Kernel: 2.6.21-31.el5rt
glibc: glibc-2.5-12
version of strace: strace -- version 4.5.15
Hardware: Tried on glibc-2.5-16.1LS21, but it is not hardware specific

 -Sripathi
-----------------------------------------------------------------------------------

Created an attachment (id=29457)
Patch to fix the problem in strace

Attached patch fixes the problem. It defines in strace all the FUTEX_* calls
that are defined in glibc. Tested by running strace on a small testcase making
mutex lock/unlock calls on a PI mutex.

 -Sripathi
-----------------------------------------------------------------------------------
Comment 1 IBM Bug Proxy 2007-07-30 06:46:56 EDT
Created attachment 160232 [details]
Patch to fix the problem in strace
Comment 2 Luis Claudio R. Goncalves 2007-08-08 14:24:47 EDT
This bug has been fixed in strace-4.5.16-1, with a patch created to fix Bug
#241467. The patch includes more futex related options:
http://bugzilla.redhat.com/bugzilla/attachment.cgi?id=155494

The package may be available soon in the repository.
Comment 3 IBM Bug Proxy 2007-09-25 10:13:16 EDT
------- Comment From sripathi@in.ibm.com 2007-09-19 09:50 EDT-------
I have verified that this is fixed in strace-4.5.16-1, which is shipping with
RHEL5.1

Note You need to log in before you can comment on or make changes to this bug.