This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 250074 - Duplicate listUserSystems in the Available methods list in apidoc
Duplicate listUserSystems in the Available methods list in apidoc
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Documentation (Show other bugs)
500
All Linux
low Severity low
: ---
: ---
Assigned To: John Ha
Content Services Development
http://rlx-1-12.rhndev.redhat.com/rhn...
: Documentation
Depends On:
Blocks: 248642
  Show dependency treegraph
 
Reported: 2007-07-30 07:11 EDT by Jan Pazdziora
Modified: 2014-08-04 18:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-31 22:01:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2007-07-30 07:11:34 EDT
Description of problem:

On the /rhn/apidoc/system/SystemHandler.jsp page, there is a list of Available
methods on the right. The listUserSystems method is shown twice, leading to the
same /rhn/apidoc/system/SystemHandler.jsp#listUserSystems target.

Version-Release number of selected component (if applicable):

Satellite 5.0.0.

How reproducible:

Deterministic.

Steps to Reproduce:
1. View the above URL.
  
Actual results:

Two listUserSystems items shown.

Expected results:

One listUserSystems item shown.

Additional info:
Comment 1 Jan Pazdziora 2007-07-30 07:12:53 EDT
I'm setting sat-5.1.0 ? flag. Maybe this is not strictly Documentation problem
as it might be generated dynamically -- if that is the case, please change the
Bugzilla Component and Assignee.
Comment 2 Brandon Perkins 2007-07-31 22:01:17 EDT
Not a Bug.  It is listed twice because the method has two different signatures,
and therefore, two different entries and links.

If the intent is to have the two links go to the two individual entries, then
that should be a new bug across all packages and methods.

If the intent is to compress N links into one (so it behaves as it does now
now), then that will also be a new bug across the board for all packages and
methods.

But from what I can see on Satellite 500, it functions as designed.

Note You need to log in before you can comment on or make changes to this bug.